summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYOUNG HO CHA2016-10-06 14:33:49 +0900
committerYOUNG HO CHA2016-10-06 14:33:49 +0900
commitbf0dc702c1bf3eea8a340c628d6aa384b9761242 (patch)
tree88d09d99bbbcb3d8bfece56ad2c1eba076753883 /PKGBUILD
downloadaur-bf0dc702c1bf3eea8a340c628d6aa384b9761242.tar.gz
initial commit
Signed-off-by: YOUNG HO CHA <ganadist@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0af270b93d78
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: YOUNG HO CHA <ganadist@gmail.com>
+pkgname=uftrace
+_commit=cc8fd74
+_commit=c47bb75
+pkgver=0.6+$_commit
+pkgrel=0
+pkgdesc="Tool to trace and analyze execution of a program written in C/C++"
+arch=(arm x86_64)
+url="https://github.com/namhyung/uftrace"
+license=('GPL2')
+groups=()
+depends=()
+makedepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+changelog=
+#source=("git+https://github.com/namhyung/$pkgname.git#commit=$_commit")
+source=("git+https://github.com/ganadist/$pkgname.git#commit=$_commit")
+noextract=()
+md5sums=('SKIP') #autofill using updpkgsums
+
+build() {
+ mkdir -p "$pkgname"/build
+ cd "$pkgname"/build
+ ../configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname"/build
+ make DESTDIR="$pkgdir/" install
+}