summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChocobo12022-12-27 02:14:33 +0800
committerChocobo12022-12-27 02:14:33 +0800
commitb7a8e41405c87ee0776a67810488aa9a889bebf6 (patch)
treeb73f8365cdbab7f73b038e3fa5ebf836f23940bc /PKGBUILD
parent069f6a525ea462d9ad91b3126db4b44a4b6a6529 (diff)
downloadaur-b7a8e41405c87ee0776a67810488aa9a889bebf6.tar.gz
upgpkg: ufw-git r1911.g506546a-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 15 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d6684a8361d9..6a65a1430823 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=ufw-git
-pkgver=r1862.g97af0c9
+pkgver=r1911.g506546a
pkgrel=1
pkgdesc="Uncomplicated firewall"
arch=('any')
url="https://launchpad.net/ufw"
license=('GPL3')
depends=('python' 'iptables')
-makedepends=('git')
+makedepends=('git' 'python-build' 'python-installer' 'python-wheel')
provides=('ufw')
conflicts=('ufw')
backup=('etc/default/ufw'
@@ -47,12 +47,22 @@ pkgver() {
printf "r%s.g%s" "$_rev" "$_hash"
}
+build() {
+ cd "ufw"
+
+ python \
+ -m build \
+ --wheel \
+ --no-isolation
+}
+
package() {
cd "ufw"
- python "setup.py" install \
- --optimize 1 \
- --root "$pkgdir"
+ python \
+ -m installer \
+ --destdir="$pkgdir" \
+ dist/*.whl
install -Dm644 "$srcdir/ufw.service" -t "$pkgdir/usr/lib/systemd/system"
}