summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBioArchLinuxBot2023-05-25 00:55:17 +0000
committerBioArchLinuxBot2023-05-25 00:55:17 +0000
commit856ec1cb440f33e271822d760d34bb20fc37f461 (patch)
treeb992f70ae750dee439220da393121115b6aba7f4 /PKGBUILD
parentec13e23095da1d0e8dd36b2d4aca801b76dc8887 (diff)
downloadaur-856ec1cb440f33e271822d760d34bb20fc37f461.tar.gz
[lilac] updated to 47.0-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8d934c87dd50..ceb1ff978b7b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_pkgname=ugene
pkgname=('ugene' 'ugene-cuda')
-pkgver=46.0
+pkgver=47.0
pkgrel=1
pkgdesc='A free open-source cross-platform bioinformatics software'
arch=('x86_64')
@@ -22,11 +22,15 @@ makedepends=(
qt5-tools
opencl-headers
)
-source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/ugeneunipro/ugene/archive/refs/tags/${pkgver}.tar.gz")
-sha256sums=('a7d7c1018072fdada9dc602afd65445825a87d6953d3e96d61613ad8c096ccb0')
+source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/ugeneunipro/ugene/archive/refs/tags/${pkgver}.tar.gz"
+ "$pkgname.patch::https://github.com/ugeneunipro/ugene/pull/1270.patch")
+sha256sums=('55f2638b9817281053f99b6e87d988fa72475ca67899b84d85036b7e9e17a202'
+ '165656a1cb04f2f88175623c8a6830f63ed606fa4d1f28ab77153da11e12d48e')
prepare() {
- sed -i "s#16384#16384l#" "${_pkgname}-${pkgver}/src/libs_3rdparty/breakpad/src/client/linux/handler/exception_handler.cc"
+ cd ${_pkgname}-${pkgver}
+ patch -p1 < $srcdir/$pkgname.patch
+ cd ${srcdir}
cp -a ${_pkgname}-${pkgver} ${_pkgname}-cuda-${pkgver}
}