summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlilac2022-03-09 04:50:39 +0800
committerlilac2022-03-09 04:50:39 +0800
commitc5dfb978b2524da1f7f5d923f3ebe7324f4a9206 (patch)
treec1b015b5d2db25432852c00ca4259d574b97f270 /PKGBUILD
parentb684a282f0632ac73f8d93902b67122e79d6a8b9 (diff)
downloadaur-c5dfb978b2524da1f7f5d923f3ebe7324f4a9206.tar.gz
[lilac] updated to 42.0-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 24 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c945ac9e4828..f73030e8a2d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
_pkgname=ugene
pkgname=('ugene' 'ugene-cuda')
-pkgver=41.0
-pkgrel=1
+pkgver=42.0
+pkgrel=2
pkgdesc='A free open-source cross-platform bioinformatics software'
arch=('x86_64')
url='http://ugene.net'
@@ -18,36 +18,49 @@ depends=(
)
makedepends=(
cuda
+ gendesk
qt5-tools
opencl-headers
)
source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/ugeneunipro/ugene/archive/refs/tags/${pkgver}.tar.gz"
- "ugene.desktop"
+ # "ugene.desktop"
)
-sha256sums=('eab798354f71d8b21e4dff94e76abc48ca0e59e3d5234bf25d269960ef4be0b9'
- '5914bc5938dc29f58aeca16233b0bb7dc5271131a3260ed749f9dc009ff3bc03')
+sha256sums=('200159838d2d2a4a701be8fb51b0e00c0ca52c4054d72c42cdd6913bbef56d53')
prepare() {
+ echo "generating desktop file"
+ gendesk -f -n --pkgname ${_pkgname} \
+ --pkgdesc "${pkgdesc}" \
+ --categories "Education;Science" \
+ --icon "${_pkgname}" \
+ --mimetypes "application/x-ugene-fa;application/x-ugene-uprj;application/x-ugene-uwl;application/x-ugene-uql;application/x-ugene-abi;application/x-ugene-aln;application/x-ugene-embl;application/x-ugene-sw;application/x-ugene-fastq;application/x-ugene-gb;application/x-ugene-gff;application/x-ugene-msf;application/x-ugene-newick;application/x-ugene-pdb;application/x-ugene-sam-bam;application/x-ugene-srfa;application/x-ugene-sto;application/x-ugene-db;application/x-ugene-scf;application/x-ugene-mmdb;application/x-ugene-hmm;" \
+ --exec "/opt/ugene/ugeneui"
+
+ sed -i "s#16384#16384l#" "${_pkgname}-${pkgver}/src/libs_3rdparty/breakpad/src/client/linux/handler/exception_handler.cc"
cp -a ${_pkgname}-${pkgver} ${_pkgname}-cuda-${pkgver}
}
build() {
cd "${_pkgname}-${pkgver}"
- qmake CONFIG+=x64 \
+ qmake \
+ CONFIG+=x64 \
+ PREFIX=/opt/${_pkgname} \
UGENE_CUDA_DETECTED=0 \
UGENE_OPENCL_DETECTED=1 \
UGENE_USE_BUNDLED_ZLIB=0 \
- UGENE_USE_BUNDLED_SQLITE=0
+ UGENE_USE_SYSTEM_SQLITE=1
make
cd "${srcdir}/${_pkgname}-cuda-${pkgver}"
CUDA_LIB_PATH=/opt/cuda/lib64 \
CUDA_INC_PATH=/opt/cuda/include \
- qmake CONFIG+=x64 \
+ qmake \
+ CONFIG+=x64 \
+ PREFIX=/opt/${_pkgname} \
UGENE_CUDA_DETECTED=1 \
UGENE_OPENCL_DETECTED=1 \
UGENE_USE_BUNDLED_ZLIB=0 \
- UGENE_USE_BUNDLED_SQLITE=0
+ UGENE_USE_SYSTEM_SQLITE=1
CUDA_LIB_PATH=/opt/cuda/lib64 \
CUDA_INC_PATH=/opt/cuda/include \
make
@@ -68,6 +81,8 @@ package_ugene-cuda() {
cuda
)
cd "${pkgname}-${pkgver}"
+ CUDA_LIB_PATH=/opt/cuda/lib64 \
+ CUDA_INC_PATH=/opt/cuda/include \
make INSTALL_ROOT=${pkgdir} install
install -d "${pkgdir}/usr/share/applications"
install -Dm644 "${srcdir}/${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"