summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdriĆ  Arrufat2020-04-09 00:39:14 +0900
committerAdriĆ  Arrufat2020-04-09 00:39:14 +0900
commit0d5428462dee387b7af4af764ed6c90d5d9947a1 (patch)
tree4c8bded9abbe1a2428d773352606fe8514df81eb /PKGBUILD
downloadaur-0d5428462dee387b7af4af764ed6c90d5d9947a1.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..195ea3ff3d27
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Adria Arrufat <swiftscythe at gmail dot com>
+
+pkgname=ugrep
+pkgver=1.8.1
+pkgrel=1
+pkgdesc="Universal grep: ultra fast searcher of file systems, text and binary files, source code, archives, compressed files, documents, and more."
+arch=(x86_64)
+license=(BSD-3)
+url="https://github.com/Genivia/ugrep"
+optdepends=('pcre: Perl regular expressions support (preferred)'
+ 'boost-libs: Perl regular expressions support'
+ 'zlib: decompress support'
+ 'bzip2: bzip file support'
+ 'xz: lzma support')
+source=("https://github.com/Genivia/ugrep/archive/v${pkgver}.tar.gz")
+sha256sums=('4ae24ef866bfbe39f5d6c3da4ca664413d773fd77283bc3ee96530e969053742')
+
+build() {
+ cd ${pkgname}-${pkgver}
+ ./build.sh --prefix=${pkgdir}/usr/
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ make install
+}