summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoroltulu2018-07-30 19:53:27 +0300
committeroltulu2018-07-30 19:53:27 +0300
commitcc866d26bf7c1441cac102914fbcde13097a6df1 (patch)
tree8645944823cf77908cdd016c21a15c729d46d980 /PKGBUILD
downloadaur-cc866d26bf7c1441cac102914fbcde13097a6df1.tar.gz
PKGBUILD .SRCINFO
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..27ddae02dbcd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Cihan Alkan <cihanalk@gmail.com>
+
+pkgname=ukui-settings-daemon
+pkgver=1.1.6
+pkgrel=1
+pkgdesc="UKUI Ayar daemon"
+url="https://mate-desktop.org"
+arch=('x86_64')
+license=('GPL')
+depends=('dbus-glib' 'libcanberra' 'libmatekbd' 'libmatemixer' 'libnotify'
+ 'ukui-desktop' 'nss' 'polkit')
+makedepends=('intltool' 'python')
+optdepends=()
+groups=('ukui')
+source=("git+https://github.com/ukui/ukui-settings-daemon.git")
+sha256sums=('SKIP')
+
+prepare() {
+ cd ${pkgname}
+ NOCONFIGURE=1 ./autogen.sh
+}
+
+build() {
+ cd ${pkgname}
+ ./configure \
+ --prefix=/usr \
+ --libexecdir=/usr/lib/${pkgname} \
+ --sysconfdir=/etc \
+ --enable-polkit \
+ --enable-pulse
+
+ #https://bugzilla.gnome.org/show_bug.cgi?id=656231
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+
+ make
+}
+
+package() {
+ cd ${pkgname}
+ make DESTDIR="${pkgdir}" install
+}