summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPetri Lehtinen2019-10-16 14:11:15 +0300
committerPetri Lehtinen2019-10-16 14:11:15 +0300
commit8a65683383d60ccc6a523746553b85e91cbe5959 (patch)
tree151e07e58e8ce057185a5b3eb5839ac3fd41cfc0 /PKGBUILD
parent02d432fcf12fe121b1c70f534f394f71e5ab066c (diff)
downloadaur-8a65683383d60ccc6a523746553b85e91cbe5959.tar.gz
Apply Linux packaging changes from commit e8927fbbb6c135cfe5cddfb59db09199b8dc59af
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index adcab92e74ca..1cfbe8c3fb59 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,19 @@
# Maintainer: Petri Lehtinen <petri@digip.org>
pkgname=ultimatetapankaikki
_sprel=2
+_commit=e8927fbbb6c135cfe5cddfb59db09199b8dc59af
pkgver=3.21+sp${_sprel}
-pkgrel=1
+pkgrel=2
pkgdesc="Classic 90s shoot-em-up game"
arch=(x86_64)
url="https://github.com/suomipelit/ultimatetapankaikki"
license=('GPL')
depends=(sdl2 sdl2_image sdl2_mixer sdl2_net)
-source=("https://github.com/suomipelit/ultimatetapankaikki/archive/v${_sprel}.tar.gz")
-md5sums=('7d43bee578ec99e8d84ad00fcd1f0282')
+source=("https://github.com/suomipelit/ultimatetapankaikki/archive/${_commit}.tar.gz")
+md5sums=('032397fe1cfcb810580a4d3206bd9f78')
build() {
- cd "$pkgname-$_sprel"
+ cd "$pkgname-$_commit"
mkdir build
cd build
cmake -DCMAKE_INSTALL_PREFIX="/usr" -DCMAKE_BUILD_TYPE=Release ..
@@ -20,7 +21,7 @@ build() {
}
package() {
- cd "$pkgname-$_sprel"
+ cd "$pkgname-$_commit"
cd build
make DESTDIR="$pkgdir/" install
}