summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRafael Soares2016-03-23 20:39:10 -0400
committerRafael Soares2016-03-23 20:39:10 -0400
commitd0599a70caf67dcebbe52b64b1c1cdd6172c5bae (patch)
tree54b070893b479e04443e468e3fd22e17b0a5a05a /PKGBUILD
downloadaur-d0599a70caf67dcebbe52b64b1c1cdd6172c5bae.tar.gz
First Commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD80
1 files changed, 80 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e2adae5cf0fe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,80 @@
+# Maintainer=rafaelsoaresbr <rafaelsoaresbr@gmail.com>
+# Package name
+pkgbase="umlet"
+pkgname=($pkgbase{-standalone,-eclipse-plugin})
+
+# Version
+pkgver=14.1.1
+pkgrel=1
+#epoch=
+_date="2016-01-14"
+_tag="${_date}_UMLet_v${pkgver}"
+
+# Generic
+pkgdesc="Free UML Tool for Fast UML Diagrams"
+arch=('any')
+url="http://www.umlet.com/"
+license=('GPLv3')
+#groups=()
+
+# Dependencies
+depends=('java-environment')
+#optdepends=()
+makedepends=('maven' 'unzip')
+#checkdepends=()
+
+# Package Relations
+#provides=()
+#conflicts=()
+replaces=('eclipse-umlet')
+
+# Others
+#backup=()
+#options=()
+#install=actor
+changelog=changelog
+
+# Sources
+source=("umlet.desktop" "https://github.com/umlet/umlet/archive/${_tag}.tar.gz")
+#source_i686=("")
+#source_x86_64=("")
+#noextract=()
+#validpgpkeys=()
+
+# Integrity
+md5sums=('SKIP' '86d2987ad76522e926584a9b4532fc50')
+#md5sums_i686=('')
+#md5sums_x86_64=('')
+#sha1sums=()
+#sha256sums=()
+
+#pkgver() {
+#}
+
+#prepare() {
+#}
+
+build() {
+ cd umlet-${_date}_UMLet_v${pkgver}
+ mvn clean install
+}
+
+#check() {
+#}
+
+package_umlet-standalone() {
+ pkgdesc="Free UML Tool for Fast UML Diagrams (Standalone Version)"
+ install -dm755 "$pkgdir/usr/share/applications/"
+ install -dm755 "$pkgdir/usr/bin/"
+ install -dm755 "$pkgdir/opt/"
+ unzip "$srcdir/umlet-${_date}_UMLet_v${pkgver}/umlet-standalone/target/umlet-standalone-${pkgver}.zip" -d "$pkgdir/opt"
+ rm "$pkgdir/opt/Umlet/umlet.desktop"
+ install -Dm644 "$srcdir/umlet.desktop" "$pkgdir/usr/share/applications/"
+}
+
+package_umlet-eclipse-plugin() {
+ pkgdesc="Free UML Tool for Fast UML Diagrams (Eclipse Plugin Version)"
+ optdepends=('eclipse')
+ install -dm755 "$pkgdir/usr/share/eclipse/plugins"
+ install -Dm644 "$srcdir/umlet-${_date}_UMLet_v${pkgver}/umlet-eclipse-plugin/target/com.umlet.plugin-${pkgver}.jar" "$pkgdir/usr/share/eclipse/plugins"
+}