summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMattia Biondi2020-05-30 19:29:31 +0200
committerMattia Biondi2020-05-30 19:29:31 +0200
commitbb878cbdc369b5c147fe9ba353afa111915be8a9 (patch)
tree1e88f0040fe3e03eeea556939af3bf68faea253b /PKGBUILD
downloadaur-bb878cbdc369b5c147fe9ba353afa111915be8a9.tar.gz
First commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3d7b0d8f8672
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Mattia Biondi <mattia biondi1 at gmail dot com>
+pkgname=umps2
+pkgver=2.0.1
+pkgrel=1
+pkgdesc="Virtual machine simulator based around the MIPS R2/3000 microprocessor."
+arch=('x86_64')
+url="http://mps.sourceforge.net/"
+license=('GPL2')
+depends=("qt4" 'libelf' 'boost' 'libsigc++' "cross-mipsel-linux-gnu-gcc")
+makedepends=('autoconf' 'make')
+conflicts=("umps2-git")
+source=("https://sourceforge.net/projects/mps/files/uMPS2/$pkgname-$pkgver.tar.gz"
+ "0001-upstream-fixes.patch")
+md5sums=('60b72c2f8e2e5ab58de4277649e5e4ce'
+ 'b8145ca1b9a4db35adb1fb2f43eabc5f')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch --forward --strip=1 --input="${srcdir}/0001-upstream-fixes.patch"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ autoreconf -fi
+ ./configure --enable-maintainer-mode --with-mips-tool-prefix=mipsel-linux-gnu-
+ make
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ make -k check
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}