summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJean Lucas2019-08-13 21:07:24 -0400
committerJean Lucas2019-08-13 21:07:24 -0400
commitc76f9e656bb4ad603fb2e66900a118a4d099a157 (patch)
tree3aabfd9912ffb4289ec1132e7cee3a5c021faa53 /PKGBUILD
parent1d970d17527b8e772e9b33e9dfc74a93f9bdd554 (diff)
downloadaur-unbound-block-hosts.tar.gz
Add git to makedepends, update pkgver schema
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 722491335ca4..03ae67c1add5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,21 @@
# Maintainer: Jean Lucas <jean@4ray.co>
pkgname=unbound-block-hosts
-pkgver=0+21+87966ee
+pkgver=0+r21+87966ee
_commit=87966ee571cdeb78b89d16aac48d8fa2935ad6b2
-pkgrel=2
-pkgdesc="Script to convert an ad-blocking hosts file (Dan Pollock's, by default) into Unbound local-data"
+pkgrel=1
+pkgdesc='Script to convert an ad-blocking hosts file into Unbound local-data'
arch=(any)
url=https://github.com/gbxyz/unbound-block-hosts
license=(GPL PerlArtistic)
depends=(perl-lwp-protocol-https)
+makedepends=(git)
source=(git+$url#commit=$_commit)
sha512sums=('SKIP')
pkgver() {
cd $pkgname
- printf 0+%s+%s $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+ printf 0+r%s+%s $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
}
package() {