summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVianney le Clément de Saint-Marcq2019-09-11 14:52:28 +0200
committerVianney le Clément de Saint-Marcq2019-09-11 14:52:28 +0200
commit0fe0a49c70807b2278a8455a4ce3948ee49ae287 (patch)
tree12a288c47c85551fa1f9261588ee36aa4973d9bd /PKGBUILD
downloadaur-0fe0a49c70807b2278a8455a4ce3948ee49ae287.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c889519229c3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Vianney le Clément de Saint-Marcq <code AT quartic·eu>
+_pkgname=undocker
+pkgname=${_pkgname}-git
+pkgver=20180209.gc951f02
+pkgrel=1
+pkgdesc="Unpacks a Docker image"
+arch=('any')
+url="https://github.com/larsks/undocker/"
+license=('GPL3')
+depends=('python')
+makedepends=('python-setuptools' 'git')
+source=("git://github.com/larsks/${_pkgname}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ _date=$(git show -s --format='%ci' | cut -d' ' -f1 | sed 's/-//g')
+ _hash=$(git show -s --format='%h')
+ echo "${_date}.g${_hash}"
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: