summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLev Gorodetskiy2022-10-15 20:48:45 -0300
committerLev Gorodetskiy2022-10-15 20:48:45 -0300
commit6e42b459b2c7c1c0e09c7be088344bbb97661a54 (patch)
tree20af049eafba0d527ee3b86ee3a3f6af4aa1b1f5 /PKGBUILD
parent39343575a03bfb405707cf8fe5f6a545f75f3d1b (diff)
downloadaur-6e42b459b2c7c1c0e09c7be088344bbb97661a54.tar.gz
Update to 1.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 24 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3cf274d41710..bf540466529f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,37 @@
-# Maintainer: droserasprout <droserasprout@tuta.io>
+# Maintainer: Lev Gorodetskiy <aur@drsr.io>
pkgname=unflac
pkgrel=1
-pkgver=r58.d677c2e
+pkgver=1.0
pkgdesc='A command line tool for fast frame accurate audio image + cue sheet splitting.'
arch=('x86_64')
url="https://git.sr.ht/~ft/$pkgname"
-license=('unknown')
-makedepends=('go' 'git')
+license=('MIT')
+makedepends=('go')
+source=("$url/archive/$pkgver.tar.gz")
depends=('ffmpeg')
-source=('git+https://git.sr.ht/~ft/unflac')
-sha256sums=('SKIP')
+sha256sums=('a09c54d04127707c3f556836590de5d2ae6a78bf17a99472b602ef983f89b7b4')
-pkgver() {
- cd "$pkgname"
- ( set -o pipefail
- git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- )
+prepare(){
+ cd "$pkgname-$pkgver"
+ mkdir -p build/
}
build() {
- cd $pkgname
- go get -u
- go build
+ cd "$pkgname-$pkgver"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ go build -o build .
}
-package() {
- cd $pkgname
- install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
+check() {
+ cd "$pkgname-$pkgver"
+ go test ./...
}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 build/$pkgname "$pkgdir"/usr/bin/$pkgname
+} \ No newline at end of file