summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJustKidding2023-09-19 07:17:42 -0500
committerJustKidding2023-09-19 07:17:42 -0500
commit1c2196bc2c275ce2452c3aa043305c40ea10943a (patch)
tree881ed624823af25c6b300b28753d2ca0bfa7fdbb /PKGBUILD
parent6a70d102488c4680db785ebfefc2f4d5d4542864 (diff)
downloadaur-1c2196bc2c275ce2452c3aa043305c40ea10943a.tar.gz
upgpkg: ungoogled-chromium 117.0.5938.88-1
upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 16 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 86e8ad6b129a..7b4b7d000d53 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
pkgname=ungoogled-chromium
-pkgver=116.0.5845.140
+pkgver=117.0.5938.88
pkgrel=1
_launcher_ver=8
_gcc_patchset=116-patchset-2
@@ -32,12 +32,18 @@ options=('!lto') # Chromium adds its own flags for ThinLTO
source=(https://commondatastorage.googleapis.com/chromium-browser-official/chromium-$pkgver.tar.xz
https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver/chromium-launcher-$_launcher_ver.tar.gz
https://github.com/stha09/chromium-patches/releases/download/chromium-$_gcc_patchset/chromium-$_gcc_patchset.tar.xz
+ add-memory-for-std-unique_ptr-in-third_party-ip.patch
+ roll-src-third_party-libavif-src-b33d9ebfc.676aded35.patch
REVERT-disable-autoupgrading-debug-info.patch
+ material-color-utilities-cmath.patch
use-oauth2-client-switches-as-default.patch)
-sha256sums=('f89677b9da05baa569fd143a3456cb5cbce8bde9ea7d10b4f3907dcd1132716c'
+sha256sums=('4691d80039e4155d1a3c4676ee68a1e526ddad61a3cf59f65d596a1a2d56c906'
'213e50f48b67feb4441078d50b0fd431df34323be15be97c55302d3fdac4483a'
'25ad7c1a5e0b7332f80ed15ccf07d7e871d8ffb4af64df7c8fef325a527859b0'
+ '7b9708f0dbfd697be7043d3cfe52da991185aa0ee29a3b8263506cd3ae4d41a9'
+ '30841fbe0785f8df584eeaa86584fe75f89da26e71df80cf536887557ddef0b6'
'1b782b0f6d4f645e4e0daa8a4852d63f0c972aa0473319216ff04613a0592a69'
+ '55e6097d347be40cffebf3ce13ba84ea92d940f60865f1bd7c9af1ef2a2ef8e1'
'e393174d7695d0bafed69e868c5fbfecf07aa6969f3b64596d0bae8b067e1711')
if (( _manual_clone )); then
@@ -55,7 +61,7 @@ source=(${source[@]}
vaapi-add-av1-support.patch
remove-main-main10-profile-limit.patch)
sha256sums=(${sha256sums[@]}
- '773743829f782fabe33d84cb7f719bd8296875e270e37f954d1561a27ace8cc4'
+ '97d67f4783702537355cdfcaad67024413102478ec5a431b2d51b454e8baea33'
'e9e8d3a82da818f0a67d4a09be4ecff5680b0534d7f0198befb3654e9fab5b69'
'e742cc5227b6ad6c3e0c2026edd561c6d3151e7bf0afb618578ede181451b307'
'be8d3475427553feb5bd46665ead3086301ed93c9a41cf6cc2644811c5bda51c')
@@ -72,8 +78,8 @@ declare -gA _system_libs=(
[harfbuzz-ng]=harfbuzz
[icu]=icu
[jsoncpp]=jsoncpp
- #[libaom]=aom # https://aomedia.googlesource.com/aom/+/706ee36dcc82
- #[libavif]=libavif # https://github.com/AOMediaCodec/libavif/commit/4d2776a3
+ #[libaom]=aom
+ [libavif]=libavif
[libdrm]=
[libjpeg]=libjpeg
[libpng]=libpng
@@ -123,16 +129,19 @@ prepare() {
patch -Np1 -i ../use-oauth2-client-switches-as-default.patch
# Upstream fixes
+ patch -Np1 -i ../add-memory-for-std-unique_ptr-in-third_party-ip.patch
+ patch -Np1 -i ../roll-src-third_party-libavif-src-b33d9ebfc.676aded35.patch
# Revert addition of compiler flag that needs newer clang
patch -Rp1 -i ../REVERT-disable-autoupgrading-debug-info.patch
+ # Build fixes
+ patch -Np0 -i ../material-color-utilities-cmath.patch
+
# Fixes for building with libstdc++ instead of libc++
patch -Np1 -i ../patches/chromium-114-maldoca-include.patch
patch -Np1 -i ../patches/chromium-114-ruy-include.patch
patch -Np1 -i ../patches/chromium-114-vk_mem_alloc-include.patch
- patch -Np1 -i ../patches/chromium-116-object_paint_properties_sparse-include.patch
- patch -Np1 -i ../patches/chromium-116-profile_view_utils-include.patch
# Custom Patches
#patch -Np1 -i ../ozone-add-va-api-support-to-wayland.patch