summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJustKidding2022-02-03 21:02:23 -0500
committerJustKidding2022-02-03 21:02:23 -0500
commit8341144248a36f9e8a384ed630a48485575b1523 (patch)
tree061f580a4abcbd009be667371fb6e17bc40e0173 /PKGBUILD
parent1a132b256b3723dce209e2125976ea7c83e437b7 (diff)
downloadaur-8341144248a36f9e8a384ed630a48485575b1523.tar.gz
upgpkg: ungoogled-chromium 98.0.4758.80-1
upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD62
1 files changed, 39 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0fe4969cb070..7c1e5e4eb734 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,10 +9,10 @@
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
pkgname=ungoogled-chromium
-pkgver=97.0.4692.99
-pkgrel=2
+pkgver=98.0.4758.80
+pkgrel=1
_launcher_ver=8
-_gcc_patchset=4
+_gcc_patchset=5
pkgdesc="A lightweight approach to removing Google web service dependency"
arch=('x86_64')
url="https://github.com/Eloston/ungoogled-chromium"
@@ -26,24 +26,26 @@ optdepends=('pipewire: WebRTC desktop sharing under Wayland'
'kdialog: support for native dialogs in Plasma'
'org.freedesktop.secrets: password storage backend on GNOME / Xfce'
'kwallet: support for storing passwords in KWallet on Plasma')
-options=('!lto') # Chromium adds its own flags for ThinLTO
+options=('debug' '!lto') # Chromium adds its own flags for ThinLTO
source=(https://commondatastorage.googleapis.com/chromium-browser-official/chromium-$pkgver.tar.xz
https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver/chromium-launcher-$_launcher_ver.tar.gz
https://github.com/stha09/chromium-patches/releases/download/chromium-${pkgver%%.*}-patchset-$_gcc_patchset/chromium-${pkgver%%.*}-patchset-$_gcc_patchset.tar.xz
- wayland-fix-binding-to-wrong-version.patch
+ downgrade-duplicate-peer-error-to-dvlog.patch
+ fix-build-break-with-system-libdrm.patch
+ use-FT_Done_MM_Var-in-CFX_Font-AdjustMMParams.patch
sql-make-VirtualCursor-standard-layout-type.patch
chromium-93-ffmpeg-4.4.patch
unbundle-ffmpeg-av_stream_get_first_dts.patch
- unexpire-accelerated-video-decode-flag.patch
use-oauth2-client-switches-as-default.patch)
-sha256sums=('c91bae205705b367f2cfc1f72ce1ee99b2ceb5edfc584e15c60a6ab5ff01ecba'
+sha256sums=('c87266e20f860a32c48affc70a769368d1b876dbad768e3aa93ee3c335944171'
'213e50f48b67feb4441078d50b0fd431df34323be15be97c55302d3fdac4483a'
- '7af5c0a55a20c0fb496b2f4448d89203a83bb1914754d864460e55e68731ef0b'
- '29541840921302060f712838ba460cd7e988148af3ce3c9dc45437fc78442a67'
- 'dd317f85e5abfdcfc89c6f23f4c8edbcdebdd5e083dcec770e5da49ee647d150'
+ 'f561145514e9d30a696a82f6a6a4eca06e664b58d7cda30dad9afb2cef341a4d'
+ '291c6a6ad44c06ae8d1b13433f0c4e37d280c70fb06eaa97a1cc9b0dcc122aaa'
+ 'edf4d973ff197409d319bb6fbbaa529e53bc62347d26b0733c45a116a1b23f37'
+ '9c9c280be968f06d269167943680fb72a26fbb05d8c15f60507e316e8a9075d5'
+ 'b94b2e88f63cfb7087486508b8139599c89f96d7a4181c61fec4b4e250ca327a'
'1a9e074f417f8ffd78bcd6874d8e2e74a239905bf662f76a7755fa40dc476b57'
'1f0c1a7a1eb67d91765c9f28df815f58e1c6dc7b37d0acd4d68cac8e5515786c'
- '2a97b26c3d6821b15ef4ef1369905c6fa3e9c8da4877eb9af4361452a425290b'
'e393174d7695d0bafed69e868c5fbfecf07aa6969f3b64596d0bae8b067e1711')
provides=('chromium')
conflicts=('chromium')
@@ -52,7 +54,7 @@ source=(${source[@]}
chromium-drirc-disable-10bpc-color-configs.conf
wayland-egl.patch)
sha256sums=(${sha256sums[@]}
- 'e01148a7e94bfd5ee288b5c5cf7df869aaae545cf48951c8d1f47264792cbf44'
+ '78da43f0f5e0b8f361cd40cbde2e2d04b4245add9e8643964f7dc9f9190f5cb7'
'babda4f5c1179825797496898d77334ac067149cac03d797ab27ac69671a7feb'
'34d08ea93cb4762cb33c7cffe931358008af32265fc720f2762f0179c3973574')
@@ -101,8 +103,16 @@ prepare() {
# runtime -- this allows signing into Chromium without baked-in values
patch -Np1 -i ../use-oauth2-client-switches-as-default.patch
- # Fix build with older ffmpeg
- patch -Np1 -i ../chromium-93-ffmpeg-4.4.patch
+ # Patches to build with ffmpeg 4.4; remove when ffmpeg 5.0 moves to stable
+ if ! pkg-config --atleast-version 59 libavformat; then
+ # Fix build with older ffmpeg
+ patch -Np1 -i ../chromium-93-ffmpeg-4.4.patch
+
+ # Substitute the custom function 'av_stream_get_first_dts' for ffmpeg 4.4;
+ # drop this for ffmpeg 5.0 which is patched to include the above function.
+ # https://crbug.com/1251779
+ patch -Np1 -i ../unbundle-ffmpeg-av_stream_get_first_dts.patch
+ fi
# Substitute the custom function 'av_stream_get_first_dts'; will need to
# switch to bundled ffmpeg when we're no longer using ffmpeg 4.4 in Arch
@@ -115,7 +125,9 @@ prepare() {
patch -Np0 -i ../unexpire-accelerated-video-decode-flag.patch
# Upstream fixes
- patch -Np1 -i ../wayland-fix-binding-to-wrong-version.patch
+ patch -Np1 -F3 -i ../downgrade-duplicate-peer-error-to-dvlog.patch
+ patch -Np1 -i ../fix-build-break-with-system-libdrm.patch
+ patch -Np1 -d third_party/pdfium <../use-FT_Done_MM_Var-in-CFX_Font-AdjustMMParams.patch
# https://chromium-review.googlesource.com/c/chromium/src/+/2862724
patch -Np1 -i ../sql-make-VirtualCursor-standard-layout-type.patch
@@ -170,6 +182,7 @@ build() {
'custom_toolchain="//build/toolchain/linux/unbundle:default"'
'host_toolchain="//build/toolchain/linux/unbundle:default"'
'is_official_build=true' # implies is_cfi=true on x86_64
+ 'symbol_level=0' # sufficient for backtraces on x86(_64)
'disable_fieldtrial_testing_config=true'
'blink_enable_generated_code_formatting=false'
'ffmpeg_branding="Chrome"'
@@ -186,10 +199,6 @@ build() {
_flags+=('icu_use_data_file=false')
fi
- if check_option strip y; then
- _flags+=('symbol_level=0')
- fi
-
# Append ungoogled chromium flags to _flags array
_ungoogled_repo="$srcdir/$pkgname-$pkgver-1"
readarray -t -O ${#_flags[@]} _flags < "${_ungoogled_repo}/flags.gn"
@@ -203,13 +212,21 @@ build() {
CFLAGS+=' -Wno-unknown-warning-option'
CXXFLAGS+=' -Wno-unknown-warning-option'
+ # Let Chromium set its own symbol level
+ CFLAGS=${CFLAGS/-g }
+ CXXFLAGS=${CXXFLAGS/-g }
+ # -fvar-tracking-assignments is not recognized by clang
+ CFLAGS=${CFLAGS/-fvar-tracking-assignments}
+ CXXFLAGS=${CXXFLAGS/-fvar-tracking-assignments}
+
# https://github.com/ungoogled-software/ungoogled-chromium-archlinux/issues/123
CFLAGS=${CFLAGS/-fexceptions}
CFLAGS=${CFLAGS/-fcf-protection}
CXXFLAGS=${CXXFLAGS/-fexceptions}
CXXFLAGS=${CXXFLAGS/-fcf-protection}
- # This appears to cause random segfaults
+ # This appears to cause random segfaults when combined with ThinLTO
+ # https://bugs.archlinux.org/task/73518
CFLAGS=${CFLAGS/-fstack-clash-protection}
CXXFLAGS=${CXXFLAGS/-fstack-clash-protection}
@@ -217,7 +234,7 @@ build() {
CXXFLAGS=${CXXFLAGS/-Wp,-D_GLIBCXX_ASSERTIONS}
gn gen out/Release --args="${_flags[*]}"
- ninja -C out/Release chrome chrome_sandbox chromedriver
+ ninja -C out/Release chrome chrome_sandbox chromedriver.unstripped
}
package() {
@@ -229,8 +246,8 @@ package() {
cd "$srcdir/chromium-$pkgver"
install -D out/Release/chrome "$pkgdir/usr/lib/chromium/chromium"
+ install -D out/Release/chromedriver.unstripped "$pkgdir/usr/bin/chromedriver"
install -Dm4755 out/Release/chrome_sandbox "$pkgdir/usr/lib/chromium/chrome-sandbox"
- ln -s /usr/lib/chromium/chromedriver "$pkgdir/usr/bin/chromedriver"
install -Dm644 ../chromium-drirc-disable-10bpc-color-configs.conf \
"$pkgdir/usr/share/drirc.d/10-$pkgname.conf"
@@ -259,7 +276,6 @@ package() {
chrome_100_percent.pak
chrome_200_percent.pak
chrome_crashpad_handler
- chromedriver
resources.pak
v8_context_snapshot.bin