summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJustKidding2024-03-10 21:31:54 -0500
committerJustKidding2024-03-10 21:31:54 -0500
commit9a78fc29d33fb146a90c2e77988171f5fb58da45 (patch)
tree8619d4912b918ffac2d861e70bbdabd695016a24 /PKGBUILD
parentfad04a0cadef9de555544b2f373aa290fce8b894 (diff)
downloadaur-9a78fc29d33fb146a90c2e77988171f5fb58da45.tar.gz
upgpkg: ungoogled-chromium 122.0.6261.111-1
upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 13 insertions, 28 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 338bff99d796..6bca46e9341b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,11 +11,11 @@
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
pkgname=ungoogled-chromium
-pkgver=122.0.6261.69
+pkgver=122.0.6261.111
pkgrel=1
_launcher_ver=8
_manual_clone=0
-_system_clang=0
+_system_clang=1
pkgdesc="A lightweight approach to removing Google web service dependency"
arch=('x86_64')
url="https://github.com/ungoogled-software/ungoogled-chromium"
@@ -24,7 +24,7 @@ depends=('gtk3' 'nss' 'alsa-lib' 'xdg-utils' 'libxss' 'libcups' 'libgcrypt'
'ttf-liberation' 'systemd' 'dbus' 'libpulse' 'pciutils' 'libva'
'libffi' 'desktop-file-utils' 'hicolor-icon-theme')
makedepends=('python' 'gn' 'ninja' 'clang' 'lld' 'gperf' 'nodejs' 'pipewire'
- 'qt5-base' 'java-runtime-headless' 'git')
+ 'rust' 'qt5-base' 'java-runtime-headless' 'git')
optdepends=('pipewire: WebRTC desktop sharing under Wayland'
'kdialog: support for native dialogs in Plasma'
'qt5-base: enable Qt5 with --enable-features=AllowQt'
@@ -36,21 +36,15 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/chrom
https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver/chromium-launcher-$_launcher_ver.tar.gz
https://gitlab.com/Matt.Jolly/chromium-patches/-/archive/${pkgver%%.*}/chromium-patches-${pkgver%%.*}.tar.bz2
support-ICU-74-in-LazyTextBreakIterator.patch
- REVERT-simplify-blink-NativeValueTraitsBase.patch
- REVERT-use-v8-Array-Iterate-for-converting-script-wrappables.patch
- chromium-constexpr.patch
- drop-flags-unsupported-by-clang16.patch
- compiler-rt-16.patch
+ drop-flag-unsupported-by-clang17.patch
+ compiler-rt-adjust-paths.patch
use-oauth2-client-switches-as-default.patch)
-sha256sums=('f5bf4085ad3173883b45ea72b483d07f50ec3aa0f7546ac3837a9d26d0b4f9c0'
+sha256sums=('0b3da2f0ca63625e84a1b36571f23591248b8fcb422ce683c09283dbfc35c309'
'213e50f48b67feb4441078d50b0fd431df34323be15be97c55302d3fdac4483a'
'1f6acf165578288dc84edc7d9dcfabf7d38f55153b63a37ee5afa929f0e2baad'
'8c256b2a9498a63706a6e7a55eadbeb8cc814be66a75e49aec3716c6be450c6c'
- '318df8f8662071cebcdf953698408058e17f59f184500b7e12e01a04a4206b50'
- '00e06b889e4face0ef41293233ce55bd52064ab040f1fdd84aa19525f8ac3601'
- 'a061f83e2b628927feb4dbc441eb54f8b8c3d81348e447cf3b90755d7cda5f54'
- '53774fd7f807ad42f77d45cab9e5480cc2bcb0a5c5138110a434407521af9607'
- '8a2649dcc6ff8d8f24ddbe40dc2a171824f681c6f33c39c4792b645b87c9dcab'
+ '3bd35dab1ded5d9e1befa10d5c6c4555fe0a76d909fb724ac57d0bf10cb666c1'
+ 'b3de01b7df227478687d7517f61a777450dca765756002c80c4915f271e2d961'
'e393174d7695d0bafed69e868c5fbfecf07aa6969f3b64596d0bae8b067e1711')
if (( _manual_clone )); then
@@ -72,7 +66,7 @@ source=("${source[@]}"
0001-ozone-wayland-implement-text_input_manager_v3.patch
0001-ozone-wayland-implement-text_input_manager-fixes.patch)
sha256sums=("${sha256sums[@]}"
- '6c2405ca58cae05ea1c8116495d7885a0f42f44ca3d70b2bd8f11c27abb23c52'
+ '927ee3d2518d7c4757ba367e98810b18a16b9468c71a4ab39f84b2282a743c23'
'9a5594293616e1390462af1f50276ee29fd6075ffab0e3f944f6346cb2eb8aec'
'8ba5c67b7eb6cacd2dbbc29e6766169f0fca3bbb07779b1a0a76c913f17d343f'
'2a44756404e13c97d000cc0d859604d6848163998ea2f838b3b9bb2c840967e3'
@@ -144,20 +138,11 @@ prepare() {
# Upstream fixes
patch -Np1 -i ../support-ICU-74-in-LazyTextBreakIterator.patch
- # Fix "error: defaulted definition of equality comparison operator cannot
- # be declared constexpr because it invokes a non-constexpr comparison
- # function" (patch for Chromium 121 from Fedora, later extended for 122)
- patch -Np1 -i ../chromium-constexpr.patch
+ # Drop compiler flag that needs newer clang
+ patch -Np1 -i ../drop-flag-unsupported-by-clang17.patch
- # Revert usage of C++20 features which likely need newer clang
- patch -Rp1 -i ../REVERT-use-v8-Array-Iterate-for-converting-script-wrappables.patch
- patch -Rp1 -i ../REVERT-simplify-blink-NativeValueTraitsBase.patch
-
- # Drop compiler flags that need newer clang
- patch -Np1 -i ../drop-flags-unsupported-by-clang16.patch
-
- # Allow libclang_rt.builtins from compiler-rt 16 to be used
- patch -Np1 -i ../compiler-rt-16.patch
+ # Allow libclang_rt.builtins from compiler-rt >= 16 to be used
+ patch -Np1 -i ../compiler-rt-adjust-paths.patch
# Fixes for building with libstdc++ instead of libc++
patch -Np1 -i ../chromium-patches-*/chromium-114-ruy-include.patch