summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJustKidding2023-12-09 09:30:40 -0500
committerJustKidding2023-12-09 09:30:40 -0500
commitb48c6c252fff36734dc059072dece4d9057397e7 (patch)
treebb40afa0ffb51314aab42b39a1a89469698cc1e4 /PKGBUILD
parent46fc2c95a4ce41723e6e1e02fda309cc7dbfe302 (diff)
downloadaur-b48c6c252fff36734dc059072dece4d9057397e7.tar.gz
upgpkg: ungoogled-chromium 120.0.6099.71-1
upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 17 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1dd4f4109afd..280b69e53d10 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
pkgname=ungoogled-chromium
-pkgver=119.0.6045.199
+pkgver=120.0.6099.71
pkgrel=1
_launcher_ver=8
_manual_clone=0
@@ -35,13 +35,13 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/chrom
https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver/chromium-launcher-$_launcher_ver.tar.gz
https://gitlab.com/Matt.Jolly/chromium-patches/-/archive/${pkgver%%.*}/chromium-patches-${pkgver%%.*}.tar.bz2
libxml2-2.12.patch
- REVERT-disable-autoupgrading-debug-info.patch
+ drop-flags-unsupported-by-clang16.patch
use-oauth2-client-switches-as-default.patch)
-sha256sums=('b1ae62beb7907d99802b74821d5198bd54a7456df1116d317da653bde8ce6388'
+sha256sums=('604755e5838ef0fd1bff4d6c5023cdda2d42ce982dda2c4be44cce487d3dd8d8'
'213e50f48b67feb4441078d50b0fd431df34323be15be97c55302d3fdac4483a'
- '09ecf142254525ddb9c2dbbb2c71775e68722412923a5a9bba5cc2e46af8d087'
+ 'ffee1082fbe3d0c9e79dacb8405d5a0e1aa94d6745089a30b093f647354894d2'
'1808df5ba4d1e2f9efa07ac6b510bec866fa6d60e44505d82aea3f6072105a71'
- '1b782b0f6d4f645e4e0daa8a4852d63f0c972aa0473319216ff04613a0592a69'
+ '8d1cdf3ddd8ff98f302c90c13953f39cd804b3479b13b69b8ef138ac57c83556'
'e393174d7695d0bafed69e868c5fbfecf07aa6969f3b64596d0bae8b067e1711')
if (( _manual_clone )); then
@@ -61,7 +61,7 @@ source=("${source[@]}"
0001-ozone-wayland-implement-text_input_manager_v3.patch
0001-ozone-wayland-implement-text_input_manager-fixes.patch)
sha256sums=("${sha256sums[@]}"
- 'c9f8747c4e96d2d62b67909895606c546fa7986e184ce1d924a25ca1c11e69e8'
+ 'e914c320883a054b3ec7463d40b9f7af4d8d750d33676dd074df952fd951d724'
'9a5594293616e1390462af1f50276ee29fd6075ffab0e3f944f6346cb2eb8aec'
'8ba5c67b7eb6cacd2dbbc29e6766169f0fca3bbb07779b1a0a76c913f17d343f'
'2a44756404e13c97d000cc0d859604d6848163998ea2f838b3b9bb2c840967e3'
@@ -74,13 +74,13 @@ sha256sums=("${sha256sums[@]}"
declare -gA _system_libs=(
#[brotli]=brotli
[dav1d]=dav1d
- [ffmpeg]=ffmpeg
+ #[ffmpeg]=ffmpeg # YouTube playback stopped working in Chromium 120
[flac]=flac
[fontconfig]=fontconfig
[freetype]=freetype2
[harfbuzz-ng]=harfbuzz
[icu]=icu
- [jsoncpp]=jsoncpp
+ #[jsoncpp]=jsoncpp # needs libstdc++
#[libaom]=aom
#[libavif]=libavif # needs https://github.com/AOMediaCodec/libavif/commit/5410b23f76
[libdrm]=
@@ -91,9 +91,9 @@ declare -gA _system_libs=(
[libxml]=libxml2
[libxslt]=libxslt
[opus]=opus
- [re2]=re2
- [snappy]=snappy
- [woff2]=woff2
+ #[re2]=re2 # needs libstdc++
+ #[snappy]=snappy # needs libstdc++
+ #[woff2]=woff2 # needs libstdc++
[zlib]=minizip
)
_unwanted_bundled_libs=(
@@ -134,16 +134,15 @@ prepare() {
# Upstream fixes
patch -Np1 -i ../libxml2-2.12.patch
- # Revert addition of compiler flag that needs newer clang
- patch -Rp1 -i ../REVERT-disable-autoupgrading-debug-info.patch
+ # Drop compiler flags that need newer clang
+ patch -Np1 -i ../drop-flags-unsupported-by-clang16.patch
# Fixes for building with libstdc++ instead of libc++
- patch -Np1 -i ../chromium-patches-*/chromium-114-ruy-include.patch
- patch -Np1 -i ../chromium-patches-*/chromium-114-vk_mem_alloc-include.patch
- patch -Np1 -i ../chromium-patches-*/chromium-117-material-color-include.patch
- patch -Np1 -i ../chromium-patches-*/chromium-119-FragmentDataIterator-std.patch
+ #patch -Np1 -i ../chromium-patches-*/chromium-114-ruy-include.patch
+ #patch -Np1 -i ../chromium-patches-*/chromium-117-material-color-include.patch
patch -Np1 -i ../chromium-patches-*/chromium-119-at-spi-variable-consumption.patch
patch -Np1 -i ../chromium-patches-*/chromium-119-clang16.patch
+ #patch -Np1 -i ../chromium-patches-*/chromium-120-std-nullptr_t.patch
# Custom Patches
sed -i '/^bool IsHevcProfileSupported(const VideoType& type) {$/{s++bool IsHevcProfileSupported(const VideoType\& type) { return true;+;h};${x;/./{x;q0};x;q1}' \
@@ -219,7 +218,7 @@ build() {
'proprietary_codecs=true'
'rtc_use_pipewire=true'
'link_pulseaudio=true'
- 'use_custom_libcxx=false'
+ 'use_custom_libcxx=true' # https://github.com/llvm/llvm-project/issues/61705
'use_sysroot=false'
'use_system_libffi=true'
'enable_hangout_services_extension=true'