summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjk2021-05-02 12:15:20 -0500
committerjk2021-05-02 12:15:20 -0500
commitfcc08612d8dc491608465e91fb8d4fa9e3fbd6a7 (patch)
tree95163d4732d5396e2c5ab8da5bf85bfe8f533517 /PKGBUILD
parentf575b0df983591fe422ae10f113034ced3deb280 (diff)
downloadaur-fcc08612d8dc491608465e91fb8d4fa9e3fbd6a7.tar.gz
upgpkg: ungoogled-chromium 90.0.4430.93-2
another test
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5a2f00f4ab7a..f7fecf8828f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -153,8 +153,6 @@ build() {
export CCACHE_SLOPPINESS=time_macros
fi
- export CFLAGS=$(printf '%s\n' "${CFLAGS//-fcf-protection/}")
-
export CC=clang
export CXX=clang++
export AR=ar
@@ -188,6 +186,10 @@ build() {
_ungoogled_repo="$srcdir/$_pkgname-$_uc_ver"
readarray -t -O ${#_flags[@]} _flags < "${_ungoogled_repo}/flags.gn"
+ # -fcf-protection breaks some third_party libraries
+ CFLAGS=$(printf '%s\n' "${CFLAGS//-fcf-protection/}")
+ CXXFLAGS="$CFLAGS"
+
# Facilitate deterministic builds (taken from build/config/compiler/BUILD.gn)
CFLAGS+=' -Wno-builtin-macro-redefined'
CXXFLAGS+=' -Wno-builtin-macro-redefined'
@@ -196,7 +198,7 @@ build() {
# Do not warn about unknown warning options
CFLAGS+=' -Wno-unknown-warning-option'
CXXFLAGS+=' -Wno-unknown-warning-option'
-
+
msg2 'Configuring Chromium'
gn gen out/Release --args="${_flags[*]}"
msg2 'Building Chromium'