summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJimmy Stelzer2018-04-01 13:35:49 -0300
committerJimmy Stelzer2018-04-01 13:35:49 -0300
commit21fcec8e9c80cd3778804f9cffb6a70eb6942320 (patch)
treebd564965b4b6002bd710b38e3770d62a1f9f05bc /PKGBUILD
parent28719cfda6aca86aa4edce988173dd71ebbb213b (diff)
downloadaur-21fcec8e9c80cd3778804f9cffb6a70eb6942320.tar.gz
Upgrade version to 4.2.2.1692
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d14fbe675245..a3a0b080e317 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,22 @@
# Maintainer: Jimmy Stelzer <jimmy dot stelzer at gmail dot com>
pkgname=uniflash
-pkgver=4.0.974
+pkgver=4.2.2.1692
pkgrel=1
pkgdesc="Universal Flash Programmer for Texas Instruments devices. Provides a single interface for programming Flash memory and executing Flash based operations on supported targets."
arch=('i686' 'x86_64')
url="http://processors.wiki.ti.com/index.php/Category:CCS_UniFlash"
license=('custom:TECHNOLOGY SOFTWARE PUBLICLY AVAILABLE by Texas Instruments Incorporated')
depends=('libudev0-shim')
-source=($pkgname.$pkgver.run::http://software-dl.ti.com/ccs/esd/uniflash/$pkgname.$pkgver.run )
-noextract=("$pkgname.$pkgver.run" )
+source=(${pkgname}_sl.$pkgver.run::http://software-dl.ti.com/ccs/esd/uniflash/${pkgname}_sl.$pkgver.run )
+noextract=("${pkgname}_sl.$pkgver.run" )
options=(!strip)
-md5sums=('1b9849d4b49071c63e09aac34df13e23')
+md5sums=('2097a3343fcc6f706f56f70b7b5d0f9b')
+sha256sums=('ea358769b9f1eb4dfacc226e16f27b054db83a8cf2c1dafcaf838d6f5487856f')
DLAGENTS=('http::/usr/bin/curl -fLC - --cookie nada -o %o %u')
prepare() {
cd "$srcdir"
msg "If you continue you will accept the license, more information at http://processors.wiki.ti.com/index.php/Category:CCS_UniFlash."
- chmod +x $pkgname.$pkgver.run
+ chmod +x ${pkgname}_sl.$pkgver.run
}
build() {
cd "$srcdir"
@@ -24,7 +25,7 @@ build() {
package() {
cd "$srcdir"
- ./uniflash.4.0.974.run --unattendedmodeui none --mode unattended --prefix $pkgdir/opt/ti/uniflash
+ ./${pkgname}_sl.$pkgver.run --unattendedmodeui none --mode unattended --prefix $pkgdir/opt/ti/uniflash
cd "$pkgdir/opt/ti/uniflash"
sed -s "s|$pkgdir||" -i UniFlash.desktop