summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJimmy Stelzer2016-10-26 17:18:02 -0200
committerJimmy Stelzer2016-10-26 17:18:02 -0200
commit28719cfda6aca86aa4edce988173dd71ebbb213b (patch)
treed59fc3b2369f69dbefba6ade4d36af40eaad0f70 /PKGBUILD
downloadaur-28719cfda6aca86aa4edce988173dd71ebbb213b.tar.gz
Create package for uniflash 4.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d14fbe675245
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Jimmy Stelzer <jimmy dot stelzer at gmail dot com>
+pkgname=uniflash
+pkgver=4.0.974
+pkgrel=1
+pkgdesc="Universal Flash Programmer for Texas Instruments devices. Provides a single interface for programming Flash memory and executing Flash based operations on supported targets."
+arch=('i686' 'x86_64')
+url="http://processors.wiki.ti.com/index.php/Category:CCS_UniFlash"
+license=('custom:TECHNOLOGY SOFTWARE PUBLICLY AVAILABLE by Texas Instruments Incorporated')
+depends=('libudev0-shim')
+source=($pkgname.$pkgver.run::http://software-dl.ti.com/ccs/esd/uniflash/$pkgname.$pkgver.run )
+noextract=("$pkgname.$pkgver.run" )
+options=(!strip)
+md5sums=('1b9849d4b49071c63e09aac34df13e23')
+DLAGENTS=('http::/usr/bin/curl -fLC - --cookie nada -o %o %u')
+prepare() {
+ cd "$srcdir"
+ msg "If you continue you will accept the license, more information at http://processors.wiki.ti.com/index.php/Category:CCS_UniFlash."
+ chmod +x $pkgname.$pkgver.run
+}
+build() {
+ cd "$srcdir"
+
+}
+
+package() {
+ cd "$srcdir"
+ ./uniflash.4.0.974.run --unattendedmodeui none --mode unattended --prefix $pkgdir/opt/ti/uniflash
+ cd "$pkgdir/opt/ti/uniflash"
+
+ sed -s "s|$pkgdir||" -i UniFlash.desktop
+ install -d "$pkgdir/usr/share/applications"
+ install -m 644 "$pkgdir/opt/ti/uniflash/UniFlash.desktop" "$pkgdir/usr/share/applications/UniFlash.desktop"
+}