summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorfelix2017-05-10 12:58:07 +0200
committerfelix2017-05-10 13:01:04 +0200
commit47b3a6a2a891e01133bdac654c59b292f0e71686 (patch)
treeb69f5ffd8cebde9845298182650ecede79d7adb1 /PKGBUILD
parenta3ee6fc904f26e0975c464114f1f1bf3af0723bc (diff)
downloadaur-47b3a6a2a891e01133bdac654c59b292f0e71686.tar.gz
Add build instructions for the hex version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ec50a9635256..ade80715cfff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,6 +5,7 @@ pkgname=(
pcf-unifont
bdf-unifont
psf-unifont
+ hex-unifont
unifont-utils
)
pkgver=9.0.06
@@ -93,6 +94,11 @@ build() {
make -j1 ttf csurttf upperttf -o distclean
;;
+ hex-unifont)
+ msg2 "Building the hex version"
+ make -j1 hex -o distclean
+ ;;
+
esac; done
}
@@ -164,6 +170,21 @@ package_psf-unifont() {
"${pkgdir}/usr/share/kbd/consolefonts/Unifont-APL8x16.psf.gz"
}
+package_hex-unifont() {
+ pkgdesc="A free bitmap font with wide Unicode support (hex version)"
+ arch=(any)
+
+ _hexdir=/usr/share/unifont
+
+ cd "$srcdir/unifont-${pkgver}/font/$_compiled"
+ install -D -m0644 "unifont-${pkgver}.hex" \
+ "${pkgdir}${_hexdir}/unifont.hex"
+ install -D -m0644 "unifont_upper-${pkgver}.hex" \
+ "${pkgdir}${_hexdir}/unifont_csur.hex"
+ install -D -m0644 "unifont_upper-${pkgver}.hex" \
+ "${pkgdir}${_hexdir}/unifont_upper.hex"
+}
+
package_unifont-utils() {
pkgdesc="A free bitmap font with wide Unicode support - utilities"
depends=('perl')