summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorneeshy2023-07-07 23:23:56 -0400
committerneeshy2023-07-07 23:23:56 -0400
commitb3804f95acdd65560a3c7cb2dc9d5eec2eaac575 (patch)
treeb91de4049e6615249a1476ee21a965146248e7e4 /PKGBUILD
parent639569a1037f8b77ecc78d1dc1553ae48c2ee923 (diff)
downloadaur-b3804f95acdd65560a3c7cb2dc9d5eec2eaac575.tar.gz
use different sources
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 14 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 07320016b759..0d7be712b961 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,19 +9,26 @@ pkgdesc="GNU Unifont Glyphs (PCF and PSF versions)"
arch=('any')
url="https://unifoundry.com/unifont/index.html"
license=('GPL2' 'custom:OFL')
-source=("https://unifoundry.com/pub/unifont/unifont-$pkgver/unifont-$pkgver.tar.gz"{,.sig})
-sha256sums=('36668eb1326d22e1466b94b3929beeafd10b9838bf3d41f4e5e3b52406ae69f1'
- 'SKIP')
+source=("https://ftp.gnu.org/gnu/unifont/unifont-$pkgver/unifont-$pkgver.pcf.gz"{,.sig}
+ "https://ftp.gnu.org/gnu/unifont/unifont-$pkgver/Unifont-APL8x16-$pkgver.psf.gz"{,.sig}
+ "https://unifoundry.com/LICENSE.txt")
+sha256sums=('9aef06a77187df2ae4bff973bbbaf8866c98ffab6c7755c6ebfb916a96b118b1'
+ 'SKIP'
+ 'f6845bb729ac22845398925b93932469b32a25cf9450c071683808b7b8db6fd6'
+ 'SKIP'
+ '1e74cb82bf476843e97c2596297b04219b1a7e51f7238944a8c031cb9401fa87')
validpgpkeys=('95D2E9AB8740D8046387FD151A09227B1F435A33') # Paul Hardy <unifoundry@unifoundry.com>
package_pcf-unifont() {
pkgdesc="GNU Unifont Glyphs (PCF version)"
- install -Dm644 "$srcdir/unifont-$pkgver/font/precompiled/unifont-$pkgver.pcf.gz" \
- "$pkgdir/usr/share/fonts/misc/unifont.pcf.gz"
+ cd "$srcdir"
+ install -Dm644 "unifont-$pkgver.pcf.gz" "$pkgdir/usr/share/fonts/misc/unifont.pcf.gz"
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
}
package_psf-unifont() {
pkgdesc="GNU Unifont Glyphs (PSF version)"
- install -Dm644 "$srcdir/unifont-$pkgver/font/precompiled/Unifont-APL8x16-$pkgver.psf.gz" \
- "$pkgdir/usr/share/kbd/consolefonts/Unifont-APL8x16.psf.gz"
+ cd "$srcdir"
+ install -Dm644 "Unifont-APL8x16-$pkgver.psf.gz" "$pkgdir/usr/share/kbd/consolefonts/Unifont-APL8x16.psf.gz"
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
}