summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoralecksandr2023-06-02 20:58:13 -0600
committeralecksandr2023-06-02 20:58:13 -0600
commite5febb87996dbe95ab117f7d83d2b0c439bfcd25 (patch)
treec99102f1ed95504edd1be493cef50d6f1ff9d699 /PKGBUILD
parentfaf15f97e82bfd315eae81a9b0591f1238e0e896 (diff)
downloadaur-e5febb87996dbe95ab117f7d83d2b0c439bfcd25.tar.gz
commitmsg
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b35a1836a76c..f9f5a10d3ed2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,8 +13,8 @@
# Move to the build directory
pkgname=unittest-c
-pkgver=1.1.0
-pkgrel=2
+pkgver=1.1.1
+pkgrel=3
epoch=
pkgdesc="unittest c is a fast and simple macro-based unit testing framework for C.
It's inspired by the Python unittest module and designed to reduce boilerplate code.
@@ -23,7 +23,7 @@ arch=('x86_64')
url="https://github.com/alecksandr26/unittest-c/archive/refs/tags/v1.1.0.tar.gz"
license=('MIT License')
depends=()
-makedepends=(gcc git make binutils coreutils c-exceptions)
+makedepends=(gcc git make binutils coreutils trycatch-c)
optdepends=(valgrind)
source=("$pkgname-$pkgver.tar.gz::$url")
md5sums=('SKIP')
@@ -46,7 +46,6 @@ package() {
mkdir -p $pkgdir/usr/lib
# Install into the package the program
- install $srcdir/$pkgname-$pkgver/include/* $pkgdir/usr/include
- install $srcdir/$pkgname-$pkgver/lib/* $pkgdir/usr/lib
-
+ cp -r $srcdir/$pkgname-$pkgver/include/* $pkgdir/usr/include
+ cp -r $srcdir/$pkgname-$pkgver/lib/* $pkgdir/usr/lib
}