summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOscar Morante2015-09-17 21:39:53 +0300
committerOscar Morante2015-09-17 21:39:53 +0300
commit4ffe141931282f57122c25c9d89c63c2f9567635 (patch)
tree567675d6f5202dc995e61004b3a12f9df2312ae9 /PKGBUILD
parent09a0e2873819776da3e974f1cdcbcd6167e7eae1 (diff)
downloadaur-4ffe141931282f57122c25c9d89c63c2f9567635.tar.gz
fix WebGL builds
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1d701b8cec22..2119b8f0d401 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ _version=5.1.0
_build=f3
_buildtag=2015091501
pkgver=${_version}${_build}+${_buildtag}
-pkgrel=1
+pkgrel=2
pkgdesc="The world's most popular development platform for creating 2D and 3D multiplatform games and interactive experiences."
arch=('x86_64')
url='https://unity3d.com/'
@@ -42,7 +42,7 @@ source=("http://download.unity3d.com/download_unity/unity-editor-installer-${pkg
noextract=("unity-editor-installer-${pkgver}.sh")
sha256sums=('77b351d80fc4b63284f118093df486e16c13d7b136debae6534245878029a5ca'
'3e0f6faad2cae20ae2784256b0f5525fc69897a889d696aa5d748db2fe8c6a14'
- '9d46d016ab4fe09a325c6d75bfdf770596ec6679e3d5e1a31934c8bc97106c32'
+ '111e8f88a4a3e592370d2d447208bb32aeee095c22c93ed290a884704d154bbb'
'7309ac206fbb6eb5f1a073bf22e2571e1a574410ab410138a19fb66c3eee21e3')
options=(!strip)
PKGEXT='.pkg.tar' # Prevent compressing of the final package
@@ -63,6 +63,9 @@ package() {
mkdir -p "${pkgdir}/opt/"
mv ${extraction_dir} ${pkgdir}/opt/Unity
+ # HACK: fixes WebGL builds by adding a symlink (python -> python2) to the PATH
+ ln -s /usr/bin/python2 ${pkgdir}/opt/Unity/Editor/python
+
# Use the launch scripts in the .desktop files
sed -i "/^Exec=/c\Exec=/usr/bin/unity-editor" "${pkgdir}/opt/Unity/unity-editor.desktop"
sed -i "/^Exec=/c\Exec=/usr/bin/monodevelop-unity" "${pkgdir}/opt/Unity/unity-monodevelop.desktop"