summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOscar Morante2017-10-05 16:48:35 +0300
committerOscar Morante2017-10-05 16:48:35 +0300
commit9cacc3070e1634b1c8922202a493de7442cc4ed3 (patch)
treef50ac8f9f19803da89c48a59b9861d40e4dc0ed2 /PKGBUILD
downloadaur-9cacc3070e1634b1c8922202a493de7442cc4ed3.tar.gz
first commit (2017.3.0b1)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..496c6dcfde8d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Oscar Morante <spacepluk at gmail dot com>
+
+_version=2017.3.0
+_build=b1
+_buildtag=20170926
+_randomstring=2ca68d182788
+_prefix=/opt/UnityBeta
+_unitydownloads="http://beta.unity3d.com/download/${_randomstring}"
+#_keepsources=yes
+
+pkgname=unity-editor-beta-facebook
+pkgver=${_version}${_build}+${_buildtag}
+pkgrel=1
+pkgdesc="Allows building your Unity projects for the Facebook-Games platform"
+arch=('x86_64')
+url='https://unity3d.com/'
+license=('custom')
+depends=('unity-editor-beta')
+makedepends=('gtk2' 'libsoup' 'libarchive')
+source=("${_unitydownloads}/UnitySetup-${_version}${_build}")
+sha1sums=('2c7e3358f4833070ac5266b0abc90aea8f4875c8')
+options=(!strip)
+PKGEXT='.pkg.tar' # Prevent compressing of the final package
+
+unity-setup() {
+ ./UnitySetup-${_version}${_build} -d "${startdir}" -l "${pkgdir}${_prefix}" -u $@
+}
+
+extract-component() {
+ msg2 "Extracting $1..."
+ yes | unity-setup -c $1 > "/tmp/$1.log"
+}
+
+prepare() {
+ chmod +x "${srcdir}/UnitySetup-${_version}${_build}"
+}
+
+package() {
+ mkdir -p "${pkgdir}${_prefix}"
+ extract-component Facebook-Games
+
+ if [ -z "${_keepsources}" ]; then
+ rm "${startdir}/UnitySetup-Facebook-Games-Support-for-Editor-${_version}${_build}.pkg"
+ fi
+}
+