summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOscar Morante2018-09-12 17:45:07 +0300
committerOscar Morante2018-09-12 17:45:07 +0300
commited022488aae30f2b1092e6592f663852560038cf (patch)
tree7d9db1300ddf9ea97127c94e5275de5e08326b8d /PKGBUILD
parent28668ef5ea58ea7008fc3cf4f661fb09a28c4835 (diff)
downloadaur-ed022488aae30f2b1092e6592f663852560038cf.tar.gz
update to new upstream version (2018.3.0b1)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 10 insertions, 31 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5043ae6e6a73..6b17137bacc0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,9 @@
# Maintainer: Oscar Morante <spacepluk at gmail dot com>
-_version=2018.2.0
-_build=f1
-_buildtag=20180709
-_randomstring=db9a69dc5569
+_version=2018.3.0
+_build=b1
+_randomstring=3f0ac31c6d6f
_prefix=/opt/UnityBeta
-_unitydownloads="http://beta.unity3d.com/download/${_randomstring}"
-#_keepsources=yes
pkgname=unity-editor-beta-facebook
pkgver=${_version}${_build}+${_buildtag}
@@ -16,34 +13,16 @@ arch=('x86_64')
url='https://unity3d.com/'
license=('custom')
depends=('unity-editor-beta')
-makedepends=('gtk3' 'libsoup' 'libarchive')
-source=("${_unitydownloads}/UnitySetup-${_version}${_build}")
-sha1sums=('25f558636adc41bc8263dc4976fd9df86d1f9f6d')
+makedepends=('cpio')
+source=("https://beta.unity3d.com/download/${_randomstring}/MacEditorTargetInstaller/UnitySetup-Facebook-Games-Support-for-Editor-${_version}${_build}.pkg")
+sha1sums=('41d875e44f02677c27d79b0e53d01e1509a5e74f')
options=(!strip)
PKGEXT='.pkg.tar' # Prevent compressing of the final package
-unity-setup() {
- ./UnitySetup-${_version}${_build} \
- --download-location="${startdir}" \
- --install-location="${pkgdir}${_prefix}" \
- --unattended $@
-}
-
-extract-component() {
- msg2 "Extracting $1..."
- yes | unity-setup --components=$1 > "/tmp/$1.log"
-}
-
-prepare() {
- chmod +x "${srcdir}/UnitySetup-${_version}${_build}"
-}
-
package() {
- mkdir -p "${pkgdir}${_prefix}"
- extract-component Facebook-Games
-
- if [ -z "${_keepsources}" ]; then
- rm "${startdir}/UnitySetup-Facebook-Games-Support-for-Editor-${_version}${_build}.pkg"
- fi
+ _dest="${pkgdir}/${_prefix}/Editor/Data/PlaybackEngines/Facebook"
+ install -d "${_dest}"
+ cd "${_dest}"
+ cat "${srcdir}/TargetSupport.pkg.tmp/Payload" | gzip -dc | cpio -i
}