summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOscar Morante2018-01-19 19:49:05 +0100
committerOscar Morante2018-01-19 19:49:05 +0100
commitf9331f77011583cb1f834d28879c868ebab8277d (patch)
tree4cdd87999538d11416b130f19606b188baa308ee /PKGBUILD
parent4be53c4cd4289bb3456dee9e3f43c6c51fbff434 (diff)
downloadaur-f9331f77011583cb1f834d28879c868ebab8277d.tar.gz
workaround bug in unity installer
There's a bug in the installer that tries to do GUI stuff when you use the contracted version of the parameters. Now it should work on chroots/headless systems.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 04f3e57678d4..11085846a376 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,12 +23,15 @@ options=(!strip)
PKGEXT='.pkg.tar' # Prevent compressing of the final package
unity-setup() {
- ./UnitySetup-${_version}${_build} -d "${startdir}" -l "${pkgdir}${_prefix}" -u $@
+ ./UnitySetup-${_version}${_build} \
+ --download-location="${startdir}" \
+ --install-location="${pkgdir}${_prefix}" \
+ --unattended $@
}
extract-component() {
msg2 "Extracting $1..."
- yes | unity-setup -c $1 > "/tmp/$1.log"
+ yes | unity-setup --components=$1 > "/tmp/$1.log"
}
prepare() {