summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOscar Morante2018-01-19 19:49:46 +0100
committerOscar Morante2018-01-19 19:49:46 +0100
commit385163fe15e74cd07d9cea86bc30c330e803b51e (patch)
tree83b77ceaf609d74b86aea31aa06e1ee84d7e2611 /PKGBUILD
parentbc7a9011c890e7a1c65a6243d52b08f212f1b6aa (diff)
downloadaur-385163fe15e74cd07d9cea86bc30c330e803b51e.tar.gz
workaround bug in unity installer
There's a bug in the installer that tries to do GUI stuff when you use the contracted version of the parameters. Now it should work on chroots/headless systems.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d72c425a9d95..6a0fcfa0eca7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,12 +23,15 @@ options=(!strip)
PKGEXT='.pkg.tar' # Prevent compressing of the final package
unity-setup() {
- ./UnitySetup-${_version}${_build} -d "${startdir}" -l "${pkgdir}${_prefix}" -u $@
+ ./UnitySetup-${_version}${_build} \
+ --download-location="${startdir}" \
+ --install-location="${pkgdir}${_prefix}" \
+ --unattended $@
}
extract-component() {
msg2 "Extracting $1..."
- yes | unity-setup -c $1 > "/tmp/$1.log"
+ yes | unity-setup --components=$1 > "/tmp/$1.log"
}
prepare() {