summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGordian Edenhofer2017-07-13 10:28:51 +0200
committerGordian Edenhofer2017-07-13 10:33:27 +0200
commit4201c94a1ce9d8b247d807f9edfa4b29a4f17fbf (patch)
treeef99f81a1eec9f2e8bf9d9ad12fd81b2b6193d15 /PKGBUILD
parente3e7f35039ae403a21dee596eaedf374c2a78a2d (diff)
downloadaur-4201c94a1ce9d8b247d807f9edfa4b29a4f17fbf.tar.gz
upgpkg: unity-editor-bin 5.6.2xf3+2017.1.0-1
Move random nonce value from the source URL into a deticated variable.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7db3ff52a951..12816fe63b74 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,15 @@
# Watch new releases at https://forum.unity3d.com/threads/unity-on-linux-release-notes-and-known-issues.350256/
-# Prevent compression of the final package since it would take too long (sereausly!)
+# Prevent compression of the final package since it would take too long (seriously!)
PKGEXT='.pkg.tar'
pkgname=unity-editor-bin
_version=5.6.2
-_build=f1
-pkgver="${_version}x${_build}"
+_build=f3
+_buildtag=2017.1.0
+_nonce=061bcf22327f
+pkgver="${_version}x${_build}+${_buildtag}"
pkgrel=1
pkgdesc="The world's most popular development platform for creating 2D and 3D multiplatform games and interactive experiences."
arch=('x86_64')
@@ -25,8 +27,8 @@ optdepends=('ffmpeg: for WebGL exporting'
provides=("unity-editor=${pkgver}")
conflicts=('unity-editor')
options=(!strip)
-source=("http://beta.unity3d.com/download/ddd95e743b51/unity-editor_amd64-${pkgver}Linux.deb")
-sha512sums=('a892897fd7234b40b21075112938b6ee4bcfd518943ecd5ea337611e692173834024f5229f12d0fb37ea42c6849cc1c4640ca09d1eea970882938f70a617911c')
+source=("http://beta.unity3d.com/download/${_nonce}/unity-editor_amd64-${_buildtag}x${_build}Linux.deb")
+sha512sums=('246e2c6e9248551f875bf5176b3206988835b86ad9e61b6f7ec1cc436615bc894bfc78fccc29bf6528d4e27a0ceee4e92a31f285616ee96ac4fb3d09137aa92b')
prepare() {
if [[ "$(df . -BG --output=avail | awk -F'[^0-9]*' 'FNR==2 {print $2;}')" -le "10" ]]; then