summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsinasio2023-12-26 09:07:17 +0100
committersinasio2023-12-26 09:07:17 +0100
commitea4b56c3d4c43f21c8ee8569db206eba64dc2041 (patch)
treecae91b2b9deaa35f4d0807b345f1db8c406bb105 /PKGBUILD
parent76603c7a259dbda849b8e2782039d42102b5c03b (diff)
downloadaur-unityhub.tar.gz
Updated UnityHub to 3.7.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 15 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 49a8136a7cad..d076494a2878 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Marius Glo <marius@mgl.dev>
pkgname=unityhub
-pkgver=3.6.1
+pkgver=3.7.0
pkgrel=1
pkgdesc="The Unity Hub is a standalone application that streamlines the way you find, download, and manage your Unity Projects and installations."
url="https://unity.com/"
@@ -12,25 +12,27 @@ arch=('x86_64')
license=('custom')
depends=('nss' 'gtk3' 'cpio' 'openssl-1.1')
optdepends=(
- 'libappindicator-gtk3: The official deb says this an optional dependency'
- 'gconf: Required by Unity 2019.4 or older'
- 'libicu50: May fix issues related to empty compiler errors'
- 'icu70: : May fix issues related to empty compiler errors'
+ 'libappindicator-gtk3: The official deb says this an optional dependency'
+ 'gconf: Required by Unity 2019.4 or older'
+ 'libicu50: May fix issues related to empty compiler errors'
+ 'icu70: : May fix issues related to empty compiler errors'
)
source=(
- "$pkgname-$pkgver.deb::https://hub.unity3d.com/linux/repos/deb/pool/main/u/unity/unityhub_amd64/unityhub-amd64-${pkgver}.deb"
- 'license.txt'
+ "$pkgname-$pkgver.deb::https://hub.unity3d.com/linux/repos/deb/pool/main/u/unity/unityhub_amd64/unityhub-amd64-${pkgver}.deb"
+ 'license.txt'
+)
+sha256sums=(
+ '7051dc7e9b07483951f363ed67495e443a6f083ea7c3441d6f73ec60a327a2c0'
+ 'f0eb3a4bb148bb7f426e4f5b97e891265ac487710cbcba9282518537c7b5d833'
)
-sha256sums=('ae91fceda16f6d86a7b61c0fc3f4a596e387febb63ea8c1c55eb410f8f9325e5'
- 'f0eb3a4bb148bb7f426e4f5b97e891265ac487710cbcba9282518537c7b5d833')
conflicts=('unityhub-beta')
OPTIONS=(!strip)
install='unityhub.install'
package() {
- tar -xf 'data.tar.bz2' -C "$pkgdir/"
- mkdir -p "$pkgdir/usr/bin"
- ln -sf '/opt/unityhub/unityhub' "$pkgdir/usr/bin/unityhub"
+ tar -xf 'data.tar.bz2' -C "$pkgdir/"
+ mkdir -p "$pkgdir/usr/bin"
+ ln -sf '/opt/unityhub/unityhub' "$pkgdir/usr/bin/unityhub"
- install -Dm644 "$srcdir/license.txt" "$pkgdir/usr/share/licenses/$pkgname/license.txt"
+ install -Dm644 "$srcdir/license.txt" "$pkgdir/usr/share/licenses/$pkgname/license.txt"
}