summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRudra Saraswat2021-10-19 23:16:42 +0530
committerRudra Saraswat2021-10-19 23:16:42 +0530
commitf53ad981235cb99b842493a6ecb41d39dc0f1cae (patch)
treed80063fc7588c17141784db97fa1534551965e57 /PKGBUILD
downloadaur-f53ad981235cb99b842493a6ecb41d39dc0f1cae.tar.gz
Add PKGBUILD and .SRCINFO
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c901129c4107
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+pkgname="unityx"
+pkgver="git"
+pkgrel=1
+pkgdesc="A modern and functional DE"
+arch=(any)
+depends=("nemo" "fish" "bash" "python3" "python-gobject" "libkeybinder3" "rofi" "feh" "xfwm4" "zenity" "pavucontrol" "blueman" "network-manager-applet" "polybar" "glib2" "conky" "pnmixer-git" "xdotool" "notify-osd" "arandr" "xorg-server-xephyr" "plotinus-unityx-git")
+makedepends=("fish" "xorg-server-xephyr")
+license=("GPL")
+source=('unityx::git+https://gitlab.com/ubuntu-unity/unity-x/unityx.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/unityx"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "${srcdir}/unityx"
+ DESTDIR="${pkgdir}" fish tools/gen_pkg.fish
+}