summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKarol Babioch2017-11-17 11:08:19 +0100
committerKarol Babioch2017-11-17 11:08:21 +0100
commit8778fad5d3b6d6719e1e8b0920deb4044c30109a (patch)
treeaa35db67e7cdc73350bc8e71d88c92d6404fc03f /PKGBUILD
parent0a7cd9653b5ace9d45e584b8a7ac72baea6e5e73 (diff)
downloadaur-8778fad5d3b6d6719e1e8b0920deb4044c30109a.tar.gz
Various cleanups
This cleans up the package and applies a patch from the comments, which makes sure the source archive is named appropriately.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD56
1 files changed, 28 insertions, 28 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 972725b584b4..b5b4ff81d5f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,47 +1,48 @@
-#Maintainer: Oleg Rakhmanov <oleg [at] archlinuxarm [dot] org>
+# Maintainer: Karol Babioch <karol@babioch.de>
+# Contributor: Oleg Rakhmanov <oleg [at] archlinuxarm [dot] org>
-pkgname=unixbench
+pkgname='unixbench'
pkgver=5.1.3
-pkgrel=3
-pkgdesc="UnixBench is a simple benchmark whose purpose is to provide a basic indicator of the performance of a Unix-like
-system."
+pkgrel=4
+pkgdesc='UnixBench is a simple benchmark whose purpose is to provide a basic indicator of the performance of a Unix-like system.'
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
license=('GPL')
url="https://github.com/kdlucas/byte-unixbench"
depends=('perl')
-source=("https://github.com/kdlucas/byte-unixbench/archive/v${pkgver}.tar.gz"
- 'no-make.patch'
- 'use_volatile.patch'
- 'make_maxcopies_unbound_for_misc_and_system_suites.patch'
- 'unreasonable_multicore-whetstone_results_fix.patch'
- 'modern_compiler_optimizations.patch'
- 'ubench')
-
-md5sums=('bf94e09faa4f620bf3bc49e70dd9851c'
- 'f3e196a745ec70bc80e552867394a3e5'
- '62fb020a60ac5b8059bf670517f460ca'
- '6dfea87ef70147d6961160529a5a4d00'
- '5de4883d86ab9e77120773790aea7ddf'
- '794cb884d98479d7d270d58bdea0def3'
- 'd0a6a418559410ca65206ec3165b8e23')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/kdlucas/byte-unixbench/archive/v${pkgver}.tar.gz"
+ 'no-make.patch'
+ 'use_volatile.patch'
+ 'make_maxcopies_unbound_for_misc_and_system_suites.patch'
+ 'unreasonable_multicore-whetstone_results_fix.patch'
+ 'modern_compiler_optimizations.patch'
+ 'ubench')
+
+sha256sums=('3a6bb00f270a5329682dff20fd2c1ab5332ef046eb54a96a0d7bd371005d31a3'
+ '4b12e902ff32ffd82fd2db889b21617f1eafaa42f9335b24d28b217e70175003'
+ 'cd7dbd374630fa4dafae7388f5535be63d32a33c681cab0da2ead499e0805948'
+ 'd574a7b4c21f764ab62c9e0bc8f9f7f3704c0655618c63e6cff32925c9fe0895'
+ '138e57267273e83f4f701246498f783e7066cea4ecc58658079d6f673041fda9'
+ 'aba3d5aa768d99763ab7cb662e4f34ba395c1342ae2f72623b1eafe2e5682b1b'
+ 'bfbb545d11fb9b5c695c4cee0fe8a9e28f1e934c0058423d37531c9bcf711f44')
prepare() {
- cd ${srcdir}/byte-unixbench-${pkgver}/UnixBench
+ cd "${srcdir}/byte-unixbench-${pkgver}/UnixBench"
+
patch -Np1 -i ${srcdir}/no-make.patch
patch -Np1 -i ${srcdir}/use_volatile.patch
patch -Np2 -i ${srcdir}/make_maxcopies_unbound_for_misc_and_system_suites.patch
patch -Np1 -i ${srcdir}/unreasonable_multicore-whetstone_results_fix.patch
patch -Np1 -i ${srcdir}/modern_compiler_optimizations.patch
-
- }
+}
build() {
- cd ${srcdir}/byte-unixbench-${pkgver}/UnixBench
+ cd "${srcdir}/byte-unixbench-${pkgver}/UnixBench"
+
make
- }
+}
package() {
- cd ${srcdir}/byte-unixbench-${pkgver}/UnixBench
+ cd "${srcdir}/byte-unixbench-${pkgver}/UnixBench"
install -dm775 ${pkgdir}/usr/bin/unixbench
cp -a {pgms,results,testdir,tmp,Run} ${pkgdir}/usr/bin/unixbench
@@ -50,6 +51,5 @@ package() {
chmod 775 ${pkgdir}/usr/bin/ubench
chmod 775 ${pkgdir}/usr/bin/unixbench/Run
chmod ugoa+w ${pkgdir}/usr/bin/unixbench/{results,testdir,tmp}
- }
-
+}