summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChris Oelmueller2015-01-02 23:11:09 +0100
committerChris Oelmueller2015-01-02 23:11:09 +0100
commita5dc25d41ecfb1c5e8fc14f009c152ae546b6e6e (patch)
treeeb8711feda8c9d5bc394762e06fb35ba02056659 /PKGBUILD
parentdfe16f7ba73664342df25aea4df7d797683d6ac2 (diff)
downloadaur-a5dc25d41ecfb1c5e8fc14f009c152ae546b6e6e.tar.gz
unknown-horizons 2014.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 14 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a297adfb3bd9..8a0fb7fe3de7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,27 +5,28 @@
# Contributor: Deather <deather.jeuxlinux@gmail.com>
# Contributor: Ronan Rabouin <darkbaboon@gmail.com>
pkgname=unknown-horizons
-pkgver=2013.3
-pkgrel=6
+pkgver=2014.1
+pkgrel=1
pkgdesc="2D realtime strategy simulation with an emphasis on economy and city building."
arch=('i686' 'x86_64')
url="http://www.unknown-horizons.org/"
license=('GPL' 'CCPL')
-depends=('fife>=0.3.5' 'python2' 'python2-pillow' 'python2-yaml')
+depends=('fife-git' 'python2' 'python2-pillow' 'python2-yaml')
makedepends=('intltool')
conflicts=('unknown-horizons-svn' 'unknown-horizons-git')
-source=("https://github.com/${pkgname}/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.xz")
-md5sums=('2417cb88c12a0f855c96743c7f3287d0')
-sha256sums=('18c2fd62365e40f6bb06b0a3c4106fff592bac249c3f498d49442f5dc217e37d')
+source=("https://github.com/${pkgname}/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.xz"
+ "fix-atlas-overlays.diff::https://github.com/unknown-horizons/unknown-horizons/commit/405c514eab9e2abffe8d1a8912646447e6a29cfa.patch")
+md5sums=('276ed6118eba6af615a286ff2989da6c'
+ 'befa5c1525bc0acbdd3b270734d51ff3')
+sha256sums=('5f9dd483e81ad89bff1bc46739349ab531cc930830bf17ef390ac239940a236b'
+ 'f393f8ca09d697ae5dc793b7693f17f3065415cc4ea8a8fabb72dfd8517bec4c')
prepare() {
- # Patch new Fife version expecting bool (not int) for logging parameters
- cd "$srcdir/$pkgname"
- sed -i -e 's@\(self._setting.get(SETTINGS.FIFE_MODULE, "LogToPrompt",\) "0"@\1 False@' "horizons/engine/engine.py"
- sed -i -e 's@\(self._setting.get(SETTINGS.FIFE_MODULE, "LogToFile",\) "0"@\1 False@' "horizons/engine/engine.py"
+ cd "$srcdir/$pkgname"
+ # Fix crash with color overlays if using atlases (the default)
+ patch -p1 -i "${srcdir}/fix-atlas-overlays.diff"
}
-
package() {
- cd "$srcdir/$pkgname"
- python2 setup.py --quiet install --root="$pkgdir" --optimize=1
+ cd "$srcdir/$pkgname"
+ python2 setup.py --quiet install --root="$pkgdir" --optimize=1
}