summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNeko-san2023-01-30 17:50:35 -0600
committerNeko-san2023-01-30 17:50:35 -0600
commit3a2cbec52830528d800780384cfa42c7b4d1cdb8 (patch)
tree3c787ecea211697718a60ea5bd211b51914a788a /PKGBUILD
parente41c47961c0457270c96523358c077ef23972a7f (diff)
downloadaur-3a2cbec52830528d800780384cfa42c7b4d1cdb8.tar.gz
Changed some sed usage and corrected an edge-case in the launch script.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 156cd5b17496..07f5bbf9cb96 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -262,6 +262,6 @@ package() {
# Configuring the launch script to detect when it has been run for the first time
# Note: Requires that there isn't already a UE5 desktop entry in "${HOME}/local/share/applications/" - delete yours if you have one there before installing this
DesktopFileChecksum=$(sha256sum "${pkgdir}/usr/share/applications/com.unrealengine.UE5Editor.desktop" | cut -f 1 -d ' ')
- sed -i "s/ChecksumPlaceholder/${DesktopFileChecksum}/" "${pkgdir}/usr/bin/unreal-engine-5.sh"
+ sed -i "s|ChecksumPlaceholder|${DesktopFileChecksum}|" "${pkgdir}/usr/bin/unreal-engine-5.sh"
sed -i "s|InstalledLocationPlaceholder|/${_install_dir}/Engine/Binaries|" "${pkgdir}/usr/bin/unreal-engine-5.sh"
}