summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNeko-san2023-07-07 03:41:23 -0500
committerNeko-san2023-07-07 03:41:23 -0500
commit6dd6ce046f4c696065e9c1e7f91600e0ca379365 (patch)
tree2f34361d8820b9e64efc342a990f267b828dba64 /PKGBUILD
parent376e1761a6adfb7d7a46d029e35cb329cc7ea101 (diff)
downloadaur-6dd6ce046f4c696065e9c1e7f91600e0ca379365.tar.gz
Changed the 'find' approach to finging the UE license to something less aggressive
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ede14fdf16de..19c0e769e244 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
# If you want additional options, there are switches below.
pkgname=unreal-engine
pkgver=5.2.1
-pkgrel=2
+pkgrel=3
pkgdesc='A 3D game engine by Epic Games which can be used non-commercially for free.'
arch=('x86_64' 'x86_64_v2' 'x86_64_v3' 'x86_64_v4' 'aarch64')
url=https://www.unrealengine.com/
@@ -221,7 +221,7 @@ package() {
if [ "${USE_DEFAULT_UE_LOGO_AT_INSTALL}" == 1 ]; then
install -Dm644 ue5editor.svg "${pkgdir}/usr/share/pixmaps/ue5editor.svg"
else
- cd "${srcdir}/${pkgname}" || return
+ mv ue5editor.svg ue5editor.svg.bak
wget --output-document "ue5editor.svg" "https://raw.githubusercontent.com/EliverLara/candy-icons/master/apps/scalable/ue4editor.svg"
install -Dm644 ue5editor.svg "${pkgdir}/usr/share/pixmaps/ue5editor.svg"
wget --output-document "LICENSE" "https://raw.githubusercontent.com/EliverLara/candy-icons/master/LICENSE"
@@ -229,10 +229,11 @@ package() {
install -Dm644 LICENSE "${pkgdir}/usr/share/UnrealEngine/EliverLara-candy-icons/"
rm ue5editor.svg
rm LICENSE
+ mv ue5editor.svg.bak ue5editor.svg
fi
# License
- install -Dm644 "$(find ${srcdir} -type f -iname 'LICENSE.md')" "${pkgdir}/usr/share/licenses/UnrealEngine/LICENSE.md"
+ install -Dm644 "${srcdir}/${pkgname}/LICENSE.md" "${pkgdir}/usr/share/licenses/UnrealEngine/LICENSE.md"
# Engine
## Set to all permissions to prevent the engine from breaking itself; more elegant solutions might exist - suggest them if they can be automated here