summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoracerix2016-06-17 18:50:50 -0400
committeracerix2016-06-17 18:50:50 -0400
commit9ded7e157dbfc696f409bfec09b2f21fee42280e (patch)
tree26e229b100f0a08f998ba38d92c4085bc97a6873 /PKGBUILD
parentf808259dd94b89b33996f43d02316ee22e2046d9 (diff)
downloadaur-9ded7e157dbfc696f409bfec09b2f21fee42280e.tar.gz
use "git clean" to make sure old version files are gone
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d3bc21567d9f..a1a1e4d9c41f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -26,11 +26,14 @@ options=(!strip staticlibs)
build() {
cd $srcdir/UnrealEngine
+
+ # clean up old build, otherwise there are errors building a new version in same dir
+ git clean -xdf
./Setup.sh
./GenerateProjectFiles.sh
- # needed to build a different version in the same build dir
+ # this should work instead of "git clean", but something leftover causes crashes
#make ARGS=-clean
make