summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoracerix2016-09-07 15:06:50 -0400
committeracerix2016-09-07 15:06:50 -0400
commitaa0751292643fc2ada8b54eef1504b61008b2a49 (patch)
treed0e371053c8a112b544cc7e864acb772e58dd973 /PKGBUILD
parente5e45c0d87dc1ab3cd9268a34682f021e01c0cc9 (diff)
downloadaur-aa0751292643fc2ada8b54eef1504b61008b2a49.tar.gz
prune dirs in find, to prevent error on child files
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1c4a190d03ef..731bd8e45e8e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -52,11 +52,11 @@ build() {
make
# delete windows-only files
- find \( -iname "Windows" -o -iname "Win64" -o -iname "vs2013" -o -iname "vs2015" \) -type d -exec rm -r "{}" \;
+ find \( -iname "Windows" -o -iname "Win64" -o -iname "vs2013" -o -iname "vs2015" \) -type d -prune -exec rm -r "{}" \;
find -iregex '.*\.\(exe\|dll\|bat\|vcx?proj\(\.filters\|\.user\)?\|sln\)$' -delete
# delete mac-only files (1+ GiB)
- find Engine/Source/ThirdParty \( -iname "IOS" -o -iname "TVOS" -o -iname "osx64" \) -type d -exec rm -r "{}" \;
+ find Engine/Source/ThirdParty \( -iname "IOS" -o -iname "TVOS" -o -iname "osx64" \) -type d -prune -exec rm -r "{}" \;
}
package() {