summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNeko-san2023-06-23 10:11:17 -0500
committerNeko-san2023-06-23 10:11:17 -0500
commitd9919275d0cc67bbf952f1f4183728c6901b166c (patch)
tree5d510e479a8cd2e5a0d41ccca7cda0260314ab47 /PKGBUILD
parent2df2b199c2bb1589a75381eedfd377d1d5be654e (diff)
downloadaur-d9919275d0cc67bbf952f1f4183728c6901b166c.tar.gz
Corrected a packaging oversight connected to the new default package icon
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 2 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index df9e227947e4..f07534f13fdd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
# If you want additional options, there are switches below.
pkgname=unreal-engine
pkgver=5.2.1
-pkgrel=0
+pkgrel=1
pkgdesc='A 3D game engine by Epic Games which can be used non-commercially for free.'
arch=('x86_64' 'x86_64_v2' 'x86_64_v3' 'x86_64_v4' 'aarch64')
url=https://www.unrealengine.com/
@@ -213,7 +213,6 @@ package() {
## Install a pacman hook to keep old builds from compounding cache by tens of GBs - 2 builds alone can reach at least 30 GBs in pacman's cache; having one only takes up about 15 GBs
install -Dm775 unreal-engine-5-pacman-cache.hook "${pkgdir}/etc/pacman.d/hooks/unreal-engine-5-pacman-cache.hook"
- cd "${srcdir}/${pkgname}" || return
install -dm755 "${pkgdir}/usr/bin"
install -dm755 "${pkgdir}/usr/share/pixmaps/"
@@ -222,7 +221,7 @@ package() {
if [ "${USE_DEFAULT_UE_LOGO_AT_INSTALL}" == 1 ]; then
install -Dm644 ue5editor.svg "${pkgdir}/usr/share/pixmaps/ue5editor.svg"
else
- mv ue5editor.svg ue5editor.svg.bak
+ cd "${srcdir}/${pkgname}" || return
wget --output-document "ue5editor.svg" "https://raw.githubusercontent.com/EliverLara/candy-icons/master/apps/scalable/ue4editor.svg"
install -Dm644 ue5editor.svg "${pkgdir}/usr/share/pixmaps/ue5editor.svg"
wget --output-document "LICENSE" "https://raw.githubusercontent.com/EliverLara/candy-icons/master/LICENSE"
@@ -230,7 +229,6 @@ package() {
install -Dm644 LICENSE "${pkgdir}/usr/share/UnrealEngine/EliverLara-candy-icons/"
rm ue5editor.svg
rm LICENSE
- mv ue5editor.svg.bak ue5editor.svg
fi
# License