summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNeko-san2023-01-30 17:35:30 -0600
committerNeko-san2023-01-30 17:35:30 -0600
commite41c47961c0457270c96523358c077ef23972a7f (patch)
tree9672e3f402779f8c3fed1e411fcd08d0d15d141f /PKGBUILD
parenta10f4e9c7d66e1fe13a106c76e7347a6b9df8790 (diff)
downloadaur-e41c47961c0457270c96523358c077ef23972a7f.tar.gz
Added error-handling for the build() function to ensure an exit if the UE build script fails.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 15 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f4dd444b61d1..156cd5b17496 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -157,11 +157,21 @@ prepare() {
build() {
cd "${pkgname}" || return
- if [ "${_WithDDC}" == true ]; then
- Engine/Build/BatchFiles/RunUAT.sh BuildGraph -target="Make Installed Build Linux" -script=Engine/Build/InstalledEngineBuild.xml -set:WithDDC=true -set:HostPlatformOnly=false -set:WithLinux=true -set:WithWin64=true -set:WithMac=false -set:WithAndroid=false -set:WithIOS=false -set:WithTVOS=false
- else
- Engine/Build/BatchFiles/RunUAT.sh BuildGraph -target="Make Installed Build Linux" -script=Engine/Build/InstalledEngineBuild.xml -set:WithDDC=false -set:HostPlatformOnly=false -set:WithLinux=true -set:WithWin64=true -set:WithMac=false -set:WithAndroid=false -set:WithIOS=false -set:WithTVOS=false
- fi
+ while true; do
+ if [ "${_WithDDC}" == true ]; then
+ Engine/Build/BatchFiles/RunUAT.sh BuildGraph -target="Make Installed Build Linux" -script=Engine/Build/InstalledEngineBuild.xml -set:WithDDC=true -set:HostPlatformOnly=false -set:WithLinux=true -set:WithWin64=true -set:WithMac=false -set:WithAndroid=false -set:WithIOS=false -set:WithTVOS=false
+ else
+ Engine/Build/BatchFiles/RunUAT.sh BuildGraph -target="Make Installed Build Linux" -script=Engine/Build/InstalledEngineBuild.xml -set:WithDDC=false -set:HostPlatformOnly=false -set:WithLinux=true -set:WithWin64=true -set:WithMac=false -set:WithAndroid=false -set:WithIOS=false -set:WithTVOS=false
+ fi
+ exit_status=$?
+
+ if [ ${exit_status} -eq 0 ]; then
+ break
+ else
+ echo "Error: Build failed; try searching the output for suspicious messages." >&2
+ exit ${exit_status}
+ fi
+ done
}
package() {