summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWilliam Tang2022-07-25 00:15:03 +0800
committerWilliam Tang2022-07-25 14:53:36 +0800
commit273df058f29dc1005541e1810ae3f113e1481485 (patch)
tree6ff4628505b90c28b15db7c75862facc46e6cd5c /PKGBUILD
parentd6f7aa14160c6237d566bf969cf4b2b9f7306437 (diff)
downloadaur-273df058f29dc1005541e1810ae3f113e1481485.tar.gz
Minor bug fixes and improvements
- Add vulkan-driver to dependency - Add suppoted IDEs to optional dependency - Preserve static libraries - Add install file
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3ad055f506c8..f9f14ebacd6c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,21 @@
pkgname=unreal-engine-bin
pkgver=5.0.3
-pkgrel=1
+pkgrel=2
pkgdesc="The world's most open and advanced real-time 3D creation tool"
arch=('x86_64')
url='https://www.unrealengine.com/'
license=('custom')
conflicts=('unreal-engine' 'unreal-engine-4' 'unreal-engine-git')
provides=('unreal-engine=5.0')
-depends=('alsa-lib' 'at-spi2-atk' 'glu' 'libicu53' 'libxcomposite' 'libxcursor'
- 'libxrandr' 'libxss' 'lttng-ust2.12' 'ncurses5-compat-libs' 'nss' 'pango')
-optdepends=('android-ndk: Android build support')
+depends=('alsa-lib' 'at-spi2-atk' 'glu' 'libicu53' 'libxcomposite' 'libxcursor' 'libxrandr'
+ 'libxss' 'lttng-ust2.12' 'ncurses5-compat-libs' 'nss' 'pango' 'vulkan-driver')
+optdepends=('android-ndk: Android build support'
+ 'clion: CLion IDE support'
+ 'code: Visual Studio Code IDE support')
DLAGENTS+=('manual::/usr/bin/echo \ \ Note: Please download the zip file manually from https://www.unrealengine.com/linux')
-source=("manual://Linux_Unreal_Engine_${pkgver}.zip"
- 'unreal-engine.desktop' 'unreal-engine.xml'
- {16,24,32,48,64,256}.png)
+source=("manual://Linux_Unreal_Engine_${pkgver}.zip" 'unreal-engine.desktop' 'unreal-engine.xml' {16,24,32,48,64,256}.png)
sha256sums=('6231f9da0092da62db5d7145410b70f3e5190efafaab7fe32c95e3f8987b23ce'
'8a71e10dee1d44ad6f85d993bdf25dd4835f6415e983125ac79a912ee0c3d905'
'752dc3628639adb84ebda281040ec106227431eb7a5f92375511d96c6ceacf91'
@@ -27,7 +27,8 @@ sha256sums=('6231f9da0092da62db5d7145410b70f3e5190efafaab7fe32c95e3f8987b23ce'
'7a96ab7db1fa191a6bd087497c2f55239d7cda01dcc226e742daa80c5bc37de2'
'2399dfb472a6c753447b847fbb144235145ca6507a60941b5295389c6fc45639')
-options=(!strip)
+options=(staticlibs !strip)
+install='unreal-engine-bin.install'
package() {
# Application files