summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcaltlgin2020-08-12 10:19:22 +1200
committercaltlgin2020-08-12 10:19:22 +1200
commit5613c0daf67bbd633cde0ffa96a5a72465304671 (patch)
treef413e4bdb1302d4c858a844fcdd82c29bc6fa9a6 /PKGBUILD
parentfabff1688abd24f44d4c3e91fa830f05f4358806 (diff)
downloadaur-5613c0daf67bbd633cde0ffa96a5a72465304671.tar.gz
Remove prepare function. Clean PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 5 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1244e027fa6e..d03898481bc9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,16 @@
pkgname=unsilence
pkgver=1.0.5
-pkgrel=1
+pkgrel=2
pkgdesc='Console Interface and Library to remove silent parts of a media file'
arch=('any')
url='https://github.com/lagmoellertim/unsilence'
license=('MIT')
-depends=('ffmpeg' 'python-argparse' 'python-rich')
+depends=('ffmpeg' 'python' 'python-argparse' 'python-rich')
makedepends=('python-setuptools')
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
sha256sums=('326b85b8c58660962d2d7880e0e44dada2be2bdd9830dc0285cbee718d382ef7')
-prepare() {
- # https://github.com/lagmoellertim/unsilence/commit/30581844096967a736cc0ea8e17abb3dbd8f81ee
- sed -i 's/ffmpeg version /ffmpeg version \\D\?/' "${pkgname}-${pkgver}/unsilence/lib/tools/ffmpeg_version.py"
-}
-
build() {
cd "${pkgname}-${pkgver}"
python setup.py build
@@ -25,8 +20,9 @@ build() {
package() {
cd "${pkgname}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
- install -Dm644 'README.md' "${pkgdir}/usr/share/doc/${pkgname}/README.md"
- install -Dm644 'LICENSE' "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" 'README.md'
+ install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" 'LICENSE'
+ rm -r "${pkgdir}/usr/lib/python"*'/site-packages/examples'
}
# vim: ts=2 sw=2 et: