summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIvan Kovmir2022-03-27 09:43:14 +0200
committerIvan Kovmir2022-03-27 09:44:06 +0200
commit63281bd58798c47ad8d5bcc1ac833ad5d8eb5471 (patch)
tree18085f1b676219393f6f9fd230130e87800f7563 /PKGBUILD
downloadaur-63281bd58798c47ad8d5bcc1ac833ad5d8eb5471.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b6d54333e521
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Ivan Kovmir <ikovmir@darkn.space>
+pkgname=untldr
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='Minimalist tldr command line client'
+arch=('any')
+url="https://github.com/unInstance/untldr"
+license=('Apache')
+depends=('curl' 'libarchive')
+conflicts=('tldr')
+replaces=('tldr')
+options=('ccache')
+install="${pkgname}.install"
+changelog="${pkgname}.changelog"
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/unInstance/${pkgname}/archive/refs/tags/v${pkgver}.tar.gz")
+md5sums=('b6c3705dcdde1bbd48e29354df383a3e')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" PREFIX="/usr" install
+}