summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLucas Rooyakkers2018-10-24 18:38:22 -0400
committerLucas Rooyakkers2018-10-24 18:38:22 -0400
commit3a9d17aab44660493c78725f8ca6324ec9a17ebb (patch)
tree91fad494e0a3c45b8ce3178a484f02424205191a /PKGBUILD
downloadaur-3a9d17aab44660493c78725f8ca6324ec9a17ebb.tar.gz
Initial Commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..512221845cd9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Mainintainer : Lucas Rooyakkers <lucas dot rooyakkers at pm dot me>
+pkgname=up-git
+pkgver=1
+pkgrel=4
+license=('Apache')
+pkgdesc="Ultimate Plumber is a tool for writing Linux pipes with instant live preview"
+url="https://github.com/akavel/up"
+arch=('x86_64')
+provides=('up')
+conflicts=('up')
+makedepends=('go')
+source=("${pkgname}::git+${url}")
+sha1sums=('SKIP')
+
+build() {
+ cd ${pkgname}
+ go build
+}
+
+package() {
+ cd ${pkgname}
+ install -Dm755 "up" "$pkgdir/usr/bin/up"
+}
+