summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFilippo Falezza2022-11-02 16:55:45 +0000
committerFilippo Falezza2022-11-02 16:55:45 +0000
commit3b82ce5c6fc0bf563708d0f55e2b9ad209bc176e (patch)
treea6692a8b70e51006bc24c931f2a881de219d15b0 /PKGBUILD
parentcceb74f44a2d5361a61b1ee2ecb2b2c3d517891c (diff)
downloadaur-3b82ce5c6fc0bf563708d0f55e2b9ad209bc176e.tar.gz
updated to latest version - moved install directory back to default: /usr/local/hhirf
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD63
1 files changed, 24 insertions, 39 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b2ab7ceeecc4..546aab459f15 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: Luis Sarmiento <Luis.Sarmiento-ala-nuclear.lu.se>
+# Co-Maintainer: effeffe - Filippo Falezza <filippo dot falezza at outlook dot com>
pkgname=upak
pkgver=10.6.8 # <-- current source doesn't have a version. We keep the last known one
-pkgrel=9
+pkgrel=10
pkgdesc="HRIBF Data Acquisition and analysis."
url="ftp://ftp.phy.ornl.gov/pub/upak/README.html"
arch=('x86_64')
@@ -10,48 +11,32 @@ license=('unknown')
depends=('libx11' 'tcsh' 'bash')
makedepends=('gcc-fortran>=4.2')
options=(staticlibs emptydirs)
-source=("ftp://ftp.phy.ornl.gov/pub/${pkgname}/${pkgname}-src.tgz"
+source=(
+ "https://ftp.phy.ornl.gov/fauxtp/${pkgname}/${pkgname}-src.tgz"
"upak.install")
-md5sums=('6fda860ff33eda39c2914f34453ce96b'
- '7d8e9e7ec0f6ed54683a65f640899e20')
-
+md5sums=(
+ 'e41040fe104b97be91697b94a78bcdee'
+ '8f74428b994ee5000ece375945b65171')
install="${pkgname}.install"
-package() {
-
- ## compile
- cd "${srcdir}/${pkgname}"
+package(){
+ cd ${srcdir}
make clean
- make -j1 INSTALLDIR="${pkgdir}/usr/bin" all # <-- this already goes to ${pkgdir} therefore must be package() not build()
-
- ## documentation (0)
- _DOCDIR=${pkgdir}/usr/share/doc/${pkgname}
- [ -d ${_DOCDIR} ] || install -d ${_DOCDIR}
-
- # correct the location of the doc dir and change executable permissions
- install -m644 ${pkgdir}/usr/bin/doc/* ${_DOCDIR}
- rm -rf ${pkgdir}/usr/bin/doc
-
- # correct the location of the file and create DOC dir
- install -Dm644 ${pkgdir}/usr/bin/*.{hep,ps,dat,make,f} ${_DOCDIR}
-
- #clean bin directory from what is already placed in the doc dir.
- rm -f ${pkgdir}/usr/bin/*.{hep,ps,dat,make,f}
-
- ## libraries
- _LIBDIR=${pkgdir}/usr/lib
- [ -d ${_LIBDIR} ] || install -d ${_LIBDIR}
-
- install -Dm644 ${pkgdir}/usr/bin/*.{a,o} ${pkgdir}/usr/lib/
-
- #clean bin directory from what is already placed in the lib dir.
- rm -f ${pkgdir}/usr/bin/*.{a,o}
-
- ## others
- cd "${srcdir}/${pkgname}"
- install -m644 Dreadme/README-Apr07 ${_DOCDIR}
- install -m644 Dreadme/readme.{tex,doc} ${_DOCDIR}
- install -m644 Dreadme/dvd.{tex,doc} ${_DOCDIR}
+ make -j1 INSTALLDIR="${pkgdir}/usr/local/hhirf" all # <-- this already goes to ${pkgdir} therefore must be package() not build()
+
+ cd ${srcdir}
+ install -m644 Dreadme/README-Apr07 $pkgdir/usr/local/hhirf/doc
+ install -m644 Dreadme/readme.{tex,doc} $pkgdir/usr/local/hhirf/doc
+ install -m644 Dreadme/dvd.{tex,doc} $pkgdir/usr/local/hhirf/doc
+
+ cd $pkgdir/usr/local/hhirf
+ for file in $(ls doc/*.doc);do
+ file=$(basename -s .doc $file)
+ ./txx doc/$file x
+ ./txxps $file
+ rm $file.txx
+ mv $file.ps doc/
+ done
}