summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorL.G. Sarmiento2015-09-14 14:28:44 +0200
committerL.G. Sarmiento2015-09-14 14:28:44 +0200
commit793fd8d5f04232607c1b081bdc92baf21c62e8ce (patch)
tree3799dcc8adf981715e029f071934b130623d4323 /PKGBUILD
parentdcce72aba0056a4275c2cafd86eec6c4df063569 (diff)
downloadaur-793fd8d5f04232607c1b081bdc92baf21c62e8ce.tar.gz
updated to 10.6.8-6
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 21 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 74713f1ced8d..703cd2cbaaf8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,28 @@
-# Maintainer: Luis Sarmiento <lgsarmientop-ala-unal.edu.co>
+# Maintainer: Luis Sarmiento <Luis.Sarmiento-ala-nuclear.lu.se>
pkgname=upak
pkgver=10.6.8
-pkgrel=5
+pkgrel=6
pkgdesc="HRIBF Data Acquisition and analysis."
url="ftp://ftp.phy.ornl.gov/pub/upak/README.html"
arch=('i686' 'x86_64')
license=('unknown')
-depends=('libx11' 'gcc-libs' 'tcsh' 'bash')
+depends=('libx11' 'tcsh' 'bash')
makedepends=('gcc-fortran>=4.2')
options=(staticlibs emptydirs)
source=("ftp://ftp.phy.ornl.gov/pub/${pkgname}/${pkgname}-src.tgz"
"gfortran_x86_64.patch"
"gfortran_i686.patch"
"upak.install")
-md5sums=('8ea938e72020b75cf1ca356d27821823'
- 'fe89246ccc894cee04f20e590bab1b36'
- 'a11d01b14c15731d21ee009de8dd3a9a'
+md5sums=('c167fd178279d88e05320c7e580b05b4'
+ '80de296d49c4cf91aac4678536c7bd7f'
+ '2989e31a42d8922c0f05c22eb7f4a8be'
'1f5d22a84125d8cbcc6ee2fdfe73ffd4')
install="${pkgname}.install"
-package() {
-msg 'patch main Makefile'
+prepare() {
+
+ msg 'patch main Makefile'
cd "${srcdir}/${pkgname}"
if [ ${CARCH} == 'x86_64' ]; then
patch -Np2 < ${srcdir}/gfortran_x86_64.patch
@@ -29,22 +30,26 @@ msg 'patch main Makefile'
patch -Np2 < ${srcdir}/gfortran_i686.patch
fi
-##compile
+}
+
+package() {
+
+ ##compile
cd "${srcdir}/${pkgname}"
make clean
make -j1 INSTALLDIR="${pkgdir}/usr/bin" all
-#libraries
+ #libraries
[ -d ${pkgdir}/usr/lib ] || install -d ${pkgdir}/usr/lib
- install -Dm644 ${pkgdir}/usr/bin/*.{a,o} ${pkgdir}/usr/lib/
-# rm -f ${pkgdir}/usr/bin/*.{a,o}
+ install -Dm644 ${pkgdir}/usr/bin/*.{a,o} ${pkgdir}/usr/lib/
+ rm -f ${pkgdir}/usr/bin/*.{a,o}
-#documentation
+ #documentation
_DOCDIR=${pkgdir}/usr/share/doc/${pkgname}
[ -d ${_DOCDIR} ] || install -d ${_DOCDIR}
install -Dm644 ${pkgdir}/usr/bin/*.{hep,ps,dat} ${_DOCDIR}
-#correct the location of the doc dir and change executable permissions
+ #correct the location of the doc dir and change executable permissions
install -m644 ${pkgdir}/usr/bin/doc/* ${_DOCDIR}
rm -rf ${pkgdir}/usr/bin/doc
@@ -53,10 +58,10 @@ msg 'patch main Makefile'
install -m644 Dreadme/readme.{tex,doc} ${_DOCDIR}
install -m644 Dreadme/dvd.{tex,doc} ${_DOCDIR}
-#clean bin directory from everything else already placed in the doc dir.
+ #clean bin directory from everything else already placed in the doc dir.
rm -f ${pkgdir}/usr/bin/*.*
-msg 'Change permissions to the usual 755 for bin files'
+ msg 'Change permissions to the usual 755 for bin files'
chmod 755 ${pkgdir}/usr/bin/*
}