aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXavier Cho2024-04-03 18:51:59 +0900
committerXavier Cho2024-04-03 18:51:59 +0900
commit8bbc3714c5137a55285e4c05090ba021748989f9 (patch)
tree1a27292892a1058df195a624ac7283bb4a31783b /PKGBUILD
parent5090d225e124f2928ca25e04f8709c704d6e154a (diff)
downloadaur-8bbc3714c5137a55285e4c05090ba021748989f9.tar.gz
Force BFD linker to workaround a build problem
Switch from Gold to BFD linker as a workaround to fix a build problem due to incompatible switch (-z).
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3a50c2eecd02..f0a011ff48ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@
_fragment="${FRAGMENT:-#branch=master}"
pkgname=upbge-git
-pkgver=139557.c3f0186638c
+pkgver=141072.9aa0853d14c
pkgrel=1
pkgdesc="Uchronia Project Blender Game Engine fork of Blender Game Engine"
arch=('i686' 'x86_64')
@@ -97,7 +97,8 @@ build() {
export CUDAHOSTCXX="$CC"
_CMAKE_FLAGS+=( -DWITH_CLANG=ON \
- -DWITH_CYCLES=ON )
+ -DWITH_CYCLES=ON \
+ -DCMAKE_LINKER_TYPE=BFD )
# Use CUDA_ARCH to build for specific GPU architecture
# Supports: single arch (sm_52) and list of archs (sm_52;sm_60)