aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXavier Cho2023-03-18 10:11:33 +0900
committerXavier Cho2023-03-18 10:11:33 +0900
commitbb983567c12849a0d604ab748f204146c87e43a8 (patch)
treed949193e3bc15868fd75fc934e51814011046fe6 /PKGBUILD
parent992d2c896e4f099899ed1693f67cc030e70a4592 (diff)
downloadaur-bb983567c12849a0d604ab748f204146c87e43a8.tar.gz
Fix the problem with missing addons
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dcabb8fe80d3..ceb769b97755 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
#shellcheck disable=SC2015
pkgname=upbge-git
-pkgver=128099.f7197011182
+pkgver=128141.37504273e18
pkgrel=1
pkgdesc="Uchronia Project Blender Game Engine fork of Blender Game Engine"
arch=("i686" "x86_64")
@@ -15,7 +15,8 @@ optdepends=("cuda: CUDA support in Cycles"
"optix>=7.1.0: OptiX support in Cycles"
"openpgl: Path guiding support in Cycles"
"usd: USD export Scene")
-makedepends=("git" "cmake" "clang" "boost" "ninja" "mesa" "llvm" wayland{,-protocols} "libxkbcommon")
+makedepends=("git" "subversion" "make" "cmake" "clang" "boost" "ninja" "mesa" "llvm" wayland{,-protocols}
+ "libxkbcommon")
provides=("blender")
conflicts=("blender")
license=("GPL")
@@ -53,8 +54,8 @@ pkgver() {
}
prepare() {
- # update the submodules
- git -C "$srcdir/upbge" submodule update --init --recursive --remote
+ make -C "$srcdir/upbge" update
+
if grep -q nvidia <(lsmod); then
git -C "$srcdir/upbge" apply -v "${srcdir}"/SelectCudaComputeArch.patch
fi