summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorpyamsoft2015-11-11 11:05:58 -0800
committerpyamsoft2015-11-11 11:05:58 -0800
commit13126d5e92418130f810af5e5a3724fe72d89417 (patch)
treebf3533fe9efb1a35bf81a5609c411a6e51b6a493 /PKGBUILD
parent08471e5d92bcd6acb7baedfda04a557844689fb6 (diff)
downloadaur-13126d5e92418130f810af5e5a3724fe72d89417.tar.gz
Update to latest git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 13 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d55b21fe3a97..07358f711d3d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=update-hosts-git
_gitname=update-hosts
pkgdesc="Generate a hosts file based on multiple sources (git)"
-pkgver=r59.4cf64b9
+pkgver=r67.114b0d1
pkgrel=1
arch=('i686' 'x86_64')
makedepends=('git')
@@ -26,16 +26,20 @@ source=("${_gitname}::git+${url}#branch=master")
###############################################################################
pkgver() {
- cd "$srcdir/$_gitname"
- # From
- # https://wiki.archlinux.org/index.php/VCS_package_guidelines#The_pkgver.28.29_function
- # If there are no tags then use number of revisions since beginning of the history:
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$srcdir/$_gitname"
+ # From
+ # https://wiki.archlinux.org/index.php/VCS_package_guidelines#The_pkgver.28.29_function
+ # If there are no tags then use number of revisions since beginning of the history:
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- cd "$srcdir/$_gitname"
- install -Dm 755 "${_gitname}" "${pkgdir}/usr/bin/${_gitname}"
- install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${_gitname}/LICENSE"
+ local _timer="${_gitname}.timer"
+ local _service="${_gitname}.service"
+ cd "$srcdir/$_gitname"
+ install -Dm 755 "${_gitname}" "${pkgdir}/usr/bin/${_gitname}"
+ install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${_gitname}/LICENSE"
+ install -Dm 644 "${_timer}" "${pkgdir}/usr/lib/systemd/system/${_timer}"
+ install -Dm 644 "${_service}" "${pkgdir}/usr/lib/systemd/system/${_service}"
}