summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorpyamsoft2015-11-11 11:10:24 -0800
committerpyamsoft2015-11-11 11:10:24 -0800
commit94bf149c4a6787f60d5e4602cce531e77a243923 (patch)
tree9ace6efbd74aee92415f005c4dd4ce533c6ea528 /PKGBUILD
parent13126d5e92418130f810af5e5a3724fe72d89417 (diff)
downloadaur-94bf149c4a6787f60d5e4602cce531e77a243923.tar.gz
Bugfix: systemd file
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 07358f711d3d..acdac60663a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=update-hosts-git
_gitname=update-hosts
pkgdesc="Generate a hosts file based on multiple sources (git)"
-pkgver=r67.114b0d1
+pkgver=r68.99c4bb4
pkgrel=1
arch=('i686' 'x86_64')
makedepends=('git')
@@ -37,9 +37,16 @@ package() {
local _timer="${_gitname}.timer"
local _service="${_gitname}.service"
cd "$srcdir/$_gitname"
+
install -Dm 755 "${_gitname}" "${pkgdir}/usr/bin/${_gitname}"
install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${_gitname}/LICENSE"
install -Dm 644 "${_timer}" "${pkgdir}/usr/lib/systemd/system/${_timer}"
install -Dm 644 "${_service}" "${pkgdir}/usr/lib/systemd/system/${_service}"
+
+ # systemd needs absolute paths
+ sed -i "s#${_gitname}#/usr/bin/${_gitname}#g" \
+ "${pkgdir}/usr/lib/systemd/system/${_service}"
+
+ unset _timer _service
}