summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKemel Zaidan2023-06-22 18:07:56 -0300
committerKemel Zaidan2023-06-22 18:07:56 -0300
commitfd2049821d261bc7647ced3abe3a9492b0cce4e4 (patch)
tree07c5c082a1f3220e9a6b93848b1d1626806181c5 /PKGBUILD
parent6f824d708470bb3ed5bfc2c99bf298bc7d8fe4d2 (diff)
downloadaur-update-notifier.tar.gz
adopting the package and fixing it
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3e8d96c7dc4d..a09bc29db638 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
-# Maintainer: Emilio Reggi <nag@mailbox.org>
-# Maintainer: Mubashshir <ahmubashshir@gmail.com>
+# Maintainer: Kemel Zaidan <kemelzaidan@gmail.com>
+# Contributor: Emilio Reggi <nag@mailbox.org>
+# Contributor: Mubashshir <ahmubashshir@gmail.com>
pkgname=update-notifier
pkgver=0.7.7
-pkgrel=4
+pkgrel=5
pkgdesc="A simple pacman update notifier"
arch=(any)
url="https://github.com/Chrysostomus/$pkgname"
-license=('MIT')
+license=('custom:MIT')
depends=('awk'
'dunst>=1.3.2-2'
'libnotify'
- 'fakeroot')
+ 'bash')
optdepends=('yaourt: for AUR support'
'gnome-terminal: for integration with gnome-update-notifications'
'pamac: for graphical update actions'
@@ -18,11 +19,12 @@ optdepends=('yaourt: for AUR support'
'trizen: for AUR support'
'pacaur: for AUR support')
makedepends=('git')
-source=("git://github.com/Chrysostomus/$pkgname")
+source=("git+https://github.com/Chrysostomus/$pkgname")
md5sums=('SKIP')
package () {
- cd "$srcdir"
+ cd "$srcdir"
+ install -Dm644 "$srcdir/$pkgname/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname/"
install -Dm755 "$srcdir/$pkgname/update-notifier" "$pkgdir/usr/bin/update-notifier"
install -Dm755 "$srcdir/$pkgname/update-checker" "$pkgdir/usr/bin/update-checker"
install -Dm755 "$srcdir/$pkgname/update-check" "$pkgdir/usr/bin/update-check"