summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAnton Semjonov2020-02-21 22:50:51 +0100
committerAnton Semjonov2020-02-21 22:50:51 +0100
commit90e29f1d57559dde355e180be01407915ca474aa (patch)
tree581ab4588ce90bac963d4d9cfca65a1ca6abac97 /PKGBUILD
parent6f6e1edda2c78f0cda708c49de219728f69fd00c (diff)
downloadaur-90e29f1d57559dde355e180be01407915ca474aa.tar.gz
add patch for crlf line-ending trimming, see issue #3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8a4d581001b9..c62756f89168 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ _pkgname=(${pkgname%-git})
pkgdesc="utility for programming AVR devices with UPDI interface using standard TTL serial port"
pkgver=v0.2.r2.3741ea7
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url="https://github.com/Polarisru/$_pkgname"
@@ -19,10 +19,12 @@ conflicts=($_pkgname)
source=(
"$pkgname::git+$url.git"
"Makefile"
+ "001_trim_crlf_line_ending.patch"
)
sha256sums=(
"SKIP"
"8145eee13c59c4723ff3b8175c41ea860117fd4fd93cfd18dd176cb74d55cd8a"
+ "96162427278f7403402c5c9436400f39af6dc00f015c9420cac8a05f466aa273"
)
pkgver() {
@@ -31,7 +33,9 @@ pkgver() {
}
prepare() {
- cp Makefile "$pkgname/"
+ cd "$pkgname/"
+ cp ../Makefile .
+ patch --forward --strip=1 --input=../001_trim_crlf_line_ending.patch
}
build() {